/build/static/layout/Breadcrumb_cap_w.png

When installing Kace agent, error says I need Powershell, but I already have it.

When trying to install ampagent-7.0.763-x86, I get an error message: "This application requires a version of Powershell to be installed." However, I am running Windows 10 Enterprise 1607 which already has PowerShell 5 installed. 

3 Comments   [ + ] Show comments
  • I'm having this exact issue, and all of my endpoints are set to undefined. The linked article is useless. Literally just says "powershell is required for agent v7 and up". Any one else resolve this one? - samlodise 3 years ago
    • Hi, I am also running Win 10 Ent 1607. I got it working by checking the box for 'Windows PowerShell 2.0" in Windows Features section of the 'Programs and Features' section of the legacy Control Panel. It's pretty weak that the new/built-in PowerShell that packs with Win 10 is not sufficient to run the new KACE agent, but I'm guessing it's to ensure back compatibility with older versions of Windows. - cor3nth 3 years ago
  • Upgrade to 7.1, this was a limitation with the 7.0 agent. - Nico_K 3 years ago
    • I just checked via our Kbox and it said that there is no newer agent available than 7.0.763 - sbaxter 3 years ago
  • we have upgraded both agent and server side and while Kace installs and runs fine on the older versions of Windows 10, it does not install on the newer versions. we still get the power shell error. - sbaxter 3 years ago

Answers (6)

Posted by: Nico_K 3 years ago
Red Belt
1
as a KACE customer you can get the login. You need it also if you want to contact support or download new versions etc.
Posted by: mveras1972 3 years ago
White Belt
1
I figured it out. I ran:

Get-ExecutionPolicy -List

        Scope ExecutionPolicy
        ----- ---------------
MachinePolicy      Restricted
   UserPolicy      Restricted
      Process       Undefined
  CurrentUser       Undefined
 LocalMachine       Undefined

From the domain side, in Group Policy: ComputerConfiguration | Administrative Templates | Windows Components | WindowsPowerShell | Turn On Script Execution was set to Disabled. We changed it to Not Configured. Problem solved.



Posted by: AbhayR 3 years ago
Red Belt
0
Check if the power shell is enabled on the machine.

https://support.quest.com/kb/225066
Posted by: mveras1972 3 years ago
White Belt
0
Unfortunately I cannot view that article as it requires a login. Is there an alternate link? Thanks.
Posted by: JLorenzo8 2 years ago
White Belt
0
There are two things that I have seen working: 

- Check if registry key associated to PowerShell is showing it as enabled: 

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1]

"Install"=dword:00000001

- Windows system environment variable should have the right path, see:

System Properties > Advanced > Environment Variables > System Variables > Path = %SYSTEMROOT%\System32\WindowsPowerShell\v1.0\


Posted by: JLorenzo8 2 years ago
White Belt
0
KACE Agent 8.1 no longer user PowerShell as core dependency for the agent installation -  KACE Systems Management Appliance 8.1 release notes.
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ