/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


No Bootable Devices Found after deploying Image to UEFI machine - STATUS: 0xc000000d on Win7 x64

04/21/2015 15578 views
I'm trying to deploy an image to a new Dell 9020 that is setup for UEFI.  The image (Win 7 SP1 X64) was created, syspreped and captured from a non-UEFI machine (legacy boot) and works fine on legacy machines.  I then setup the System Image with:
Pre-Installation task of "Create UEFI Partitions"
Mid-Level Task of installing the BCDfile to S: (as per Post by Gerald Mack)
Mid-Level Task of "Apply UEFI Partitions".

I boot the new 9020 with a WinPE-5 based KBE USB drive created for UEFI, the setup, image deploy and driver feed deploy work without a problem.  When the computer restarts I get "Windows failed to start....FILE: \EFI\Microsoft\Boot\BCD      STATUS: 0xc000000d    INFO: An error occurred while attempting to read the boot configuration data".   Then the No bootable devices found prompt.

What Am I missing?
Thanks. Russ
Answer Summary:
1 Comment   [ + ] Show comment

Comments

  • You are trying to use a image that was captured from a non-UEFI system and apply it to a UEFI system?

    I am pretty sure that is the issue as that image will not have the system partitioned the way UEFI needs to be. For example, Windows 7 by default creates a separate 100MB hidden partition that contains the boot information. The image you captured probably has that partition. However, that partition is setup for what is now called Legacy Boot. The difference is that Legacy Boot had the BIOS control the boot sequence, UEFI allows Windows to. When installing in UEFI mode, 7 creates a 128MB hidden partition (it is even hidden from Disk Management) that holds the UEFI boot information.

    If you want a UEFI compatible image you need to first install 7 in UEFI mode on a UEFI machine then capture that image.

Answer Chosen by the Author

2
Trying to image a new Dell 9020 and Latitude E5450 with Windows 7 UEFI, secure boot off. 
The Enable Legacy Option ROMs box needs to be checked - under Advanced Boot options.  Even if you are using UEFI Only.
Answered 04/21/2015 by: rjobe
Fourth Degree Green Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ