/build/static/layout/Breadcrumb_cap_w.png

KScript not modifying registry values

I'm using K1000 to edit a single registry value on machines running 7.2. I have the script set up for testing currently, targeting a single testing machine. I have attempted running it as both Local System and giving it domain admin credentials. It is set up to be able to run without a logged-in user. The task is set up as follows:

O8Z3yH.pngZc4W8x.png

The issue that I am having is that the registry value is not changing. It defaults to 0x00000010 (16), and remains there. It does not update to 0x00000020 (32). I have attempted running with data set to both "32" and "0x00000020", and the change does not take with either one.

EDIT: I have attempted to run this using a registry file and batch file. This solution is tested and works when the batch file is stored locally on the test machine and the registry file is on a network drive that is accessible. However, running the same batch file through KACE does not succeed.


The registry file is as follows: 
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings]
"BranchReadinessLevel"=dword:20

0 Comments   [ + ] Show comments

Answers (1)

Answer Summary:
Posted by: CandyBee 3 years ago
White Belt
0

Top Answer

After some further research into the issue, it was discovered that KACE defaults to a 32-bit registry editor. Given that the targeted systems are all 64-bit versions of Windows, an edit was made to the initial KScript to instead target HKLM64\ and this resolved the issue.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ