/bundles/itninjaweb/img/Breadcrumb_cap_w.png
I had to uninstall and reinstall a few computers on our network to fix their Inventory check in's. I have one computer that although I have done this it still will not check in. I ran runkbot.exe 4 0 on it. And i see it creates the KAgent.log file  then there is an error when its trying to rename the KAgent.log to KAgent1.log  permission denied.  So went and gave everyone read write access to the directory is was working in C:\ProgramData\Dell\Kace and ran the runkbot again and same error. This makes No sense at all.  Everyone can read write to that directory. I went there in a dos box and did a ren KAgent.log KAgent1.log and it worked.   Anyone else have this problem? 
3 Comments   [ - ] Hide Comments

Comments

  • The machine is windows 7 64bit Pro. Not sure where the Kuid's in registry would be or what they are for. Where is the amp.conf and ill look at it.
    • This content is currently hidden from public view.
      Reason: Removed by member request
      For more information, visit our FAQ's.
  • There is only one things in the amp.conf and that is

    host=kbox1

    that is the name of the k1000 on our network.
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
  • Ok I was able to resolve this. I did the registry clean up as noted before this did not solve it. I then uninstalled the client and told it to remove data. and reinstalled. This did not help. I then uninstalled it told it to clear data and then deleted the Kace folders from programdata and programfiles 86 directory. Then i had a thought and not sure if this helped too. I deleted the machine from kace too. Reinstalled. And it was reporting again.
Please log in to comment

Answer this question or Comment on this question for clarity

Answers

0
What OS version?

Try deleting the the kuid's from the registry and also check the settings in your amp.conf file.  I do not think that error is your show stopper for inventory not working. 
Answered 10/19/2016 by: SMal.tmcc
Red Belt

  • There is only one things in the amp.conf and that is

    host=kbox1

    that is the name of the k1000 on our network.
    • Look at your amp_auto,conf. they both should have the fqdn of the kbox in them not the common name.

      Change it to the fqdn using amptools
      example:
      amptools resetconf host=kbox1.acme.com
      • We have 90+ machines that are all set to just kbox1 and kbox1 is in dns and they work. The error shows permission denied when trying to change the name of the log file from KAgent.log to KAgent1.log how will this help?
      • if it is turely an access error you can fix that by removing the client, delete the dell\kace dir under program data and reinstall. It will fix the rights needed
    • FYI
      Windows Reset KUID

      On the client machine, stop the ‘Dell KACE Agent’ service.
      Start > Run > Services.msc
      Go to the Registry using regedit and navigate to:
      (x86 Computers): HKEY_LOCAL_MACHINE | Software | Dell | Kace
      (x64 Computers): HKEY_LOCAL_MACHINE | Software | WOW6432Node | Dell | Kace
      Delete the follow two keys:
      MachineID
      InstallID
      Restart the 'Dell Kace Agent' service or reboot the computer. This wil create new KUID entries.
Please log in to comment