Kace 7.0 - Failed to "Apply UEFI Partitions" when using legacy onboard nic

When using legacy PXE boot I am unable to deploy my win 10 images, this doesn't occur in UEFI PXE boot but I don't always have this option available

The deployment fails at the middle level task: Apply UEFI Partitions

I have not been able to find any useful information on this issue

Heres the script:

bcdedit /set {bootmgr} device partition=s:

bcdedit /set {memdiag} device partition=s:

bcdedit /set {default} device partition=c:

bcdedit /set {default} osdevice partition=c:

Bcdedit /set {FWbootmgr} displayorder {Bootmgr} /addfirst

I've tried enabling logging to see what the error was but can't find any log outputs

I've tried running the commands manually but BCDEDIT wont execute commands (my research says privilege issues but the CMD says administrator at the top)

I need any way around this

1 Comment   [ + ] Show comment
  • UEFI deployments do not work on systems that only have legacy PXE boot. The bios does not support the newer UEFI format. - jboling 1 year ago

Answers (2)

Posted by: SMal.tmcc 1 year ago
Red Belt

Why do you not always have the UEFI option available for PXE?

  • I was mistaken!
    The option to turn UEFI Network Stack was nowhere to be found in the bios
    but alas while I was away at lunch my colleague managed to locate the option!

    This solved one issue - theron324 1 year ago
    • Good, but you should be following the Best Practices Guide.


      This will guide you into properly building a Single Partitioned Image (with the letter C: as the only partition), that can be deploy to Legacy and UEFI devices, using the exact same tasks.

      (make sure your SDA is on version 7.x) - Channeler 1 year ago
      • Thank you for this I will read through it - theron324 1 year ago
Posted by: theron324 1 year ago
White Belt

After tirelessly searching a solution was found for the "Apply UEFI Partition"

This script was copied from another member from an older post:

bcdedit /store S:\efi\microsoft\boot\bcd /set {bootmgr} device partition=s:
bcdedit /store S:\efi\microsoft\boot\bcd /set {memdiag} device partition=s:
bcdedit /store S:\efi\microsoft\boot\bcd /set {default} device partition=c:
bcdedit /store S:\efi\microsoft\boot\bcd /set {default} osdevice partition=c:
Bcdedit /store S:\efi\microsoft\boot\bcd /set {FWbootmgr} displayorder {Bootmgr} /addfirst

bootsect /nt60 s:

Apparently when Legacy PXE booting into Kace the PATH environment variable for bcdedit is incorrect for "Apply UEFI Partitions" and must be declared as such

  • Mmmmm.... There's one thing I'm not following here... and I think I need clarification, I will use a "popular device" as an example:

    When I look at my Optiplex 7050 Boot Options... I see these three PXE boot options:

    A. Legacy: OnBoard NIC
    B. UEFI: OnBoard NIC(IPv4)
    C. UEFI: OnBoard NIC(IPv6)

    So.. If I'm planning to capture or deploy a UEFI Image... it seems to me like Option B is the common sense option... Why would I choose to boot in Legacy... If I'm deploying a UEFI Image?

    Or maybe I'm not seeing the real issue here... just curious....

    And even if booting from Legacy works... Have you tried booting without the help from ChainBoot?
    (that means, make sure the device has no Ethernet Cable plugged in, and boot to Windows, run DISKPART, type LIST DISK, and see if there's a GPT partiton flagged).

    If there's none, that was a Legacy Deployment. If it's GPT, you should see a * under GPT when doing the LIST DISK command. - Channeler 1 year ago
    • Heres the story:
      I am about to upgrade a few hundred workstations from windows 7 32bit to windows 10 64bit

      Many of these will be remote deployments and while I could involve people in these remote locations I'd prefer not to.

      Well to accomplish this task a few BIOS settings are required to be set

      Of course this can be accomplished via Dell CCTK

      At the time of writing this question, a whole 24 hours ago, I was trying to find a way to deploy the UEFI image to a machine which did not have UEFI boot options available

      Well I had searched the bios settings head to toe and did not see the UEFI Network Stack option, silly me didn't even bother to attempt to turn it on via Dell CCTK

      Later this option was found and I realized I should have just enabled it in CCTK - theron324 1 year ago
      • oh okok, wow 32 bits... it's been years for me since I have used one of those.

        it makes sense now... sorry I was in a WTF state... but now I get it. - Channeler 1 year ago
    • Yes the deployment was a successful UEFI Image :) - theron324 1 year ago
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ