/build/static/layout/Breadcrumb_cap_w.png

Ticket Template Misalignment When Converting to Process

We have a custom ticket template with a 3-column layout that serves as the parent ticket for a process. When users navigate to the user portal and submit a ticket in the queue, the layout appears correctly. However, when submitting a process, the layout is misaligned, appearing as a 2-column layout on the left-hand side of the screen.

The reason for utilizing a process vs a ticket is due to an approval being needed. After consulting with KACE support, I learned that approvals should be used with processes, not regular tickets.

Despite reporting this layout issue to support, they have been unable to identify why it is occurring. Any insights would be greatly appreciated.

Ticket template layout example:


Process layout example:



0 Comments   [ + ] Show comments

Answers (2)

Posted by: sven.hain 1 week ago
Second Degree Green Belt
0

Hi,

just for my understanding. You create a ticket for example to request a new hardware. You convert this ticket to a process since an approval is needed and then the columns are not correct?

Did you choose the Ticket Layout template correctly in your process template that you use during the creation of the process?

GpaxcrPNvsIAAAAASUVORK5CYII=

Hope that helps :)


Cheers Sven


Comments:
  • Hi Sven,

    Thank you for your response. Initially, I created a ticket template that included the APPROVAL_INFO field and restricted the approvers to a specific label we created. Subsequently, we set up a ticket rule to notify owners and approvers when a ticket is submitted so that it can be approved. I had assumed that approvers could log in to the User portal and approve tickets, but I was unable to get it to work.

    After contacting support, I learned that approvals should be handled through processes rather than tickets. I have since updated our approach. Now, instead of submitting a ticket, users will submit a process for approval. Once approved, the process begins.

    To address your question, yes, the ticket layout template is correctly selected within the process. I included screenshots in my initial post to highlight the differences in formatting. - rruhl 1 week ago
Posted by: AmberSDNB 1 week ago
Blue Belt
0

What do you have set on this screen? Do you have "For process only" selected? Is the template Enabled? (Service Desk -> Configuration -> Queues -> Your queue -> "Customize these values" under "Ticket Defaults" -> Ticket Templates)
wd0Qxq42iVgCAAAAABJRU5ErkJggg==

Do you have a "process type" set up for it as well? (Service Desk -> Configuration -> Define Process Types)
xERCphQCUiUgkDKhGRShhQiYhUwoBKRKQSBlQiIpUwoBIRqYQBlYhIJQyoRESqAP4fsh856KOes4QAAAAASUVORK5CYII=

Then in the Process Template you have what's shown in screenshot 1 as your parent ticket?
wNE+AgNL5P3SAAAAABJRU5ErkJggg==


Comments:
  • Hi Amber,

    To answer your questions:

    1. I have "For Process Only" selected and the template is enabled. I have also tried without it selected. I believe this option just specifies whether or not it can be submitted as a ticket or process.
    2. I have a process type defined.
    3. The parent ticket shows "Untitled" for some reason. I have a name defined for the ticket template, so I am not sure why it appears that way. - rruhl 1 week ago
    • Sounds like the wrong parent ticket is attached. Did you try re-adding the parent ticket? (and make sure it has the correct name) - AmberSDNB 1 week ago
      • When I click on the parent ticket, it shows the proper ticket. However, the layout is not correct. I have also recreated the process entirely to no avail. The KACE engineer I am working with is discussing the behavior internally with his team. - rruhl 1 week ago
    • Good morning, so I tried it in my SMA as well and first it did not work either. Once I selected "For Process only" in the ticket layout template under the queue configuration, it showed correctly in my process template creation. It is important after changing that option to create a new process template since you can not change the existing process and parent ticket.

      Before the change to process only, it also only showed "Default" as a layout which was confusing since my layout has a specific name. Can you maybe send a screenshot of your ticket layout template under the queue configuration? You said it also does not display the correct name if you create a new ticket within the process which shows that something is not ok. - sven.hain 4 days ago
      • Hi Sven, thank you for the response. This is exactly what the issue was. After creating a new template and assigning it to the process, it now displays correctly. It does still show "Default" rather than the name. - rruhl 3 days ago
      • Good morning, sounds very good. Glad to hear that it works now for you :) Have a great day. - sven.hain 2 days ago

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ