/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Hello,

Like this topic ( http://itninja.com/question/gnu,-freeware-and-shareware-programs-to-cloning2418&mpage=1&key=& ) I can't use the MSI via GPO.

I use Win2k Pro (fresh install) (W2k because it's beter for MSI (XP have more services, résidents, etc.)).

I install Repackager, make a snapshot, install and configure WINRAR 3.80 FR, make a new snapshot, check file/registre, and make the MSI.

I can install MSI in a virtual machine under XP Pro updated.

I make a GPO in my domain (win 2003) (it's not the first GPO with software deployement), but, nothing.

I have 3 records in Windows Event Log :
101, 103 and 108, but no explicit message.


I activated the Windows Installer LOG, I have this :



=== Verbose logging started: 03/02/2009 15:40:09 Build type: SHIP UNICODE 3.01.4000.4039 Calling process: \??\C:\WINDOWS\system32\winlogon.exe ===
MSI (c) (B0:60) [15:40:09:890]: User policy value 'DisableRollback' is 0
MSI (c) (B0:60) [15:40:09:890]: Machine policy value 'DisableRollback' is 0
1: 2905 2: C:\WINDOWS\system32\appmgmt\MACHINE\{a671fb2c-155f-4d07-93b5-dcbf4b61571a}.aas
MSI (c) (B0:60) [15:40:09:906]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (c) (B0:60) [15:40:09:906]: DoAdvertiseScript is returning: 1603
=== Verbose logging stopped: 03/02/2009 15:40:09 ===



NTFS/share permissions are ok.


Have you an idea ? A solution ?

Thanks you.
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
Hi Jey,

How are you deploying through GPO, published, assigned, per-user, per-machine?
Could you turn on GPO logging to find out more when the GPO applies.

MSI (c) (B0:60) [15:40:09:906]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
1402 Could not open key: [2]. System error [3].

So it seems that there is an issue with accessing the rollback script key.
Answered 02/03/2009 by: AngelD
Red Belt

Please log in to comment
0
Thanks for your help !

It's a GPO per-machine (computer configuration + computer in the OU).
It's a assigned package.


How to turn on and use GPO logging ?

For the accessing problem to "rollback script key" (?), have you a idea/solution ?
Answered 02/03/2009 by: Jey
Yellow Belt

Please log in to comment
0
Answered 02/04/2009 by: AngelD
Red Belt

Please log in to comment