How to pass passwords containing " and \ in schtasks.exe command to create a scheduled task which should run under the context of a service account

I am trying to create a  scheduled task which has to run in the context of a service account.

Used schtasks.exe within a custom action in an msi to do this.

However, if the service account password contains characters such as " and \, this task is failing.

Is there any way to pass passwords containing these characters into the parameter /RP.

Already tried options like ', ^, etc. but still does not work.

0 Comments   [ + ] Show comments

Answers (0)

Be the first to answer this question

This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ