/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


Getting the K1000 to patch immediately during Patch schedule

03/07/2016 2850 views
Good afternoon!

At some point in the updating of our K1000 a setting has been changed or a bug has been introduced.

I utilize our K1000 to deploy security patches to our production environment.  These virtual machines are crucial to our environment so I can't simply schedule them and let it run at any time.  So my routine in the past was the set up certain groups with a patch label attached. Then click run now. In the past it would start the detect within a few minutes and then proceed along the patching/rebooting/verifying steps.

Now when I try the same patching using the same method the status simply says "Scheduled". Then at some point the detect and patch will occur, but that can be hours later. I have tried doing a force inventory so that it triggers the patch, but that hasn't worked either.   We get very defined windows for patching so it makes it almost impossible to use the patching in the manner that is available right now.

Any help is appreciated.

I'm on 6.3.113399.  I have about 700 inventoried machines, but my inventory frequency is set to 15 minutes which allows for 53 connections per minute.

Thanks

Answer Summary:
0 Comments   [ + ] Show comments

Comments


Answer Chosen by the Author

1
With an inventory frequency that high your appliance might have a backlog of tasks. You really shouldn't need to inventory your machines that frequently and your machines are probably constantly running the KInventory process. Under settings, Provisioning, Communication Settings what is your task throughput and current load average? You might also want to look at Settings, Support, Display Agent Task Status to see how many tasks are waiting.
Answered 03/08/2016 by: chucksteel
Red Belt

All Answers

This content is currently hidden from public view.
Reason: Removed by member request For more information, visit our FAQ's.
0
Task throughput is 2, and the current load is 1.36.
Answered 03/08/2016 by: jhsauls
Senior White Belt

  • You might also want to check under Logs, System Performance to see if things are maxing out at some point.
    • Thanks, I'll check it out.
0
So based upon Chuck's suggestions I changed a couple of settings, most notably the inventory frequency. I changed it to 2 hours, down from 30 minutes.  I just tested a scheduled patch with just a detect and it started the next step within a minute of kicking it off.

Thanks Chuck!
Answered 03/08/2016 by: jhsauls
Senior White Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ