/build/static/layout/Breadcrumb_cap_w.png
09/24/2019 150 views

The queue that is sending emails uses smtp.office365.com and port 587. I used the exact same settings for the new queue and it worked at first but back in February it just stopped sending emails. I've verified the password is correct and was able to log into the email. 

The Exim Main Log is as follows:

2019-09-24 14:13:29 1iCqFd-000DOT-Ps <= Email@Domain.com U=www P=local S=923

2019-09-24 14:13:29 1iCqFd-000DNt-1s => Email <Email@Domain.com> R=helpdesk T=helpdesk_pipe

2019-09-24 14:13:29 1iCqFd-000DNt-1s Completed

2019-09-24 14:13:30 1iCqFd-000DOI-MO [40.97.153.146] SSL verify error: certificate name mismatch: DN="/C=US/ST=Washington/L=Redmond/O=Microsoft Corporation/CN=outlook.com" H="lyh-efz.ms-acdc.office.com"

2019-09-24 14:13:36 1iCqFd-000DOI-MO auth_login authenticator failed H=lyh-efz.ms-acdc.office.com [40.97.153.146] 535 5.7.3 Authentication unsuccessful [BN6PR2001CA0018.namprd20.prod.outlook.com]

2019-09-24 14:13:44 1iCqFd-000DOI-MO == myEmail@Domain.com R=smart_route T=transport_587 defer (-42): authentication required but authentication attempt(s) failed

2019-09-24 14:22:06 Warning: purging the environment.


Answer Summary:
2 Comments   [ + ] Show comments

Comments

  • The first thing I am noticing is the SSL verify error. Does the working queue get that error as well?
    • Yes it does. I almost wanted to take that out because I'm not sure if it has anything to do with the email not working.
  • I fixed the issue. It was the password. I can't explain it. I used the same password to log into outlook and it worked. Reset the password and now it's firing off emails again. Go figure.

Answer Chosen by the Author

1

I fixed the issue. It was the password. I can't explain it. I used the same password to log into outlook and it worked. Reset the password and now it's firing off emails again. Go figure.

Answered 09/25/2019 by: caitlynmcorey
White Belt

  • FM
    at least you got it going again. Does someone else have access to this area? Something like unchecking and rechecking the smtp setting box could reset that. I have seen little things like that change stuff it should not. If you do not have history tracking enabled I would turn it on, that helps to track "unknowns" you can track settings changes that way
    • Where is the history tracking setting?
      • I have multi orgs so it is in system and each org separately. In the left column click on settings and you will see history under that. Subscriptions settings configures what setting changes to track and reporting lets you see the history You can also track asset and object changes under the other buttons
    • Looks like we have history enabled forever. But I'm not sure when it was enabled. Everything looks new like it was just enabled when we upgraded.
      • I only keep a month so I don't know if the 10 upgrade clears that as part of its house keeping or not, been on 10 since June (beta)

All Answers

1

it does not like microsofts cert any longer


see this article "Microsoft to Bid Farewell to SHA-1 in February"


https://www.infosecurity-magazine.com/news/microsoft-to-bid-farewell-to-sha-1/

Answered 09/24/2019 by: SMal.tmcc
Red Belt

  • Good to know for the future since we'll be implementing Service Desk pretty soon.
  • This appears to be old. I got excited when I saw February because Feb 2019 is when it stopped working but I'm not sure this issue has anything to do with the email not working.
    • have you tried to restart the kbox to see if it helps
      also what version of kbox?
      • I believe we have. Last week we upgraded so I assume it would have been restarted then. The problem occurred long before the upgrade and is still a problem after the upgrade.
      • have you tried to run a connection test on the Service Desk › Configuration › Service Desk Queue Email Settings page to see what results you get?
      • Weird it won't let me reply to your other comment. Yes I did try the connection test.

        Connection Test SMTP
        [Wed Sep 25 11:15:54 CDT 2019] Starting SMTP connection test to smtp.office365.com:587.
        [Wed Sep 25 11:15:54 CDT 2019] Sending SMTP test email to myEmail.
        [Wed Sep 25 11:15:56 CDT 2019] Test email was successfully sent.
        [Wed Sep 25 11:15:56 CDT 2019] SMTP Connection test is successful.