/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


Why JQS service not installed?

02/27/2011 2359 views
Hi All,
I created a MST for my Java 6.24 rollout using many of the options suggested here and in the Package KB. I don't understand what modification I made to make the JQS service not install, I was merely setting it to disabled...I thought. I installed this on a PC that had a non-modified version 6.17 and JQS installed and running, the install will kill JQS, iexplorer, etc. Here is a summary of changes. Why was the JQS service not installed? Thanks!


Property Table:
AUTOUPDATECHECK = 0
EULA = 1
IEXPLORER = 1
JAVAUPDATE = 0
JU = 0
MOZILLA = 1
SYSTRAY = 0

RemoveFile Table:
Changed the InstallMode from 3 to 2 for everything in this table except the following entries.

JAVAEXE 1
JAVAWEXE 1
JAVAWSEXE 1
ext 2
CLASSLIST 2
JAVADIR 2
binkernel 3
binkerneldir 3
bundles 3
bundlesdir 3
INSTALLDIRPATCHERR 3
INSTALLDIRENTITLEMENT 3
INSTALLDIRDistributionREADME 3
INSTALLDIRPerpetual_Entitlements 3
SHAREDARCHIVE 3
tmp 3
tmpdir 3
tmplib 3
tmplibdir 3
tmplibext 3
tmplibextdir 3
tmplibi386 3
tmplibi386dir 3

InstallExecuteSequence:
UninstallJQS NOT Installed 3187
InstallFinalize 3188
0 Comments   [ + ] Show comments

Comments



Community Chosen Answer

2
What did you do with the 'jqs.exe' in 'RemoveFiles' table? Did you remove the entry?
Answered 02/28/2011 by: WiseAppPackager
Purple Belt

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

All Answers

0
was looking for an answer to similar query about JQS and got the answer as well. thanks.
Answered 02/28/2011 by: vish_zen
Senior Yellow Belt

0
@WiseAppPackager, I changed the value of jqs.exe from 3 to 2. I did not remove any enteries from the RemoveFiles table, I only changed the value from 3 to 2 for everything except what I listed above.
Answered 02/28/2011 by: LikeToCode
Senior Yellow Belt

0
change it to 4 that solve issue quicktime
Answered 02/28/2011 by: clueless
Senior Yellow Belt

0
@Clueless Thanks but my question is why was the service not installed when I expected it to just be set to Disabled.
Answered 02/28/2011 by: LikeToCode
Senior Yellow Belt

0
Hi OP,
the line:

UninstallJQS NOT Installed 3187

did the trick.
It uninstalls the service right away with its own weapons... :-)

Regards, Nick
Answered 02/28/2011 by: nheim
10th Degree Black Belt

0
@nheim, Thanks! I thought that was the entry as well but I was thinking it would just set the service to disabled since it was already installed with version 6.17. I'm not complaining though, no service is better than disabled service! LOL
Answered 02/28/2011 by: LikeToCode
Senior Yellow Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ