Visual Studio 2017 silent install problems

I am in the process of creating a new silent install for Visual Studio 2017 update 6.
I have created the offline layout and added our product key to the response file as I have done for the previous versions. When comparing the response file with previous versions they are almost identical with all the commas and quotes in the right places. the only difference is the options that are being installed this time around.

When I run the install command (either via run or cmd) the silent install completes successfully, which indicates that the response file is correct and files have downloaded successfully to create the offline layout.

However, when I run the deployment job via Altiris the deployment script runs through initial system checks as normal, starts the install process then fails with a 5002 error. The bootstrapper log file indicates 'illegal characters in path' but the exact same command works when run manually.

Any ideas?


1 Comment   [ + ] Show comment
  • Has anyone else been experiencing problems with Visual studio silent installation recently???

    Really struggling on this one. I've run it as a local install as previously suggested and have even downloaded the offline layout again but I'm still getting the same 5002 error. - morph1006 2 years ago

Answers (3)

Answer Summary:
Posted by: anonymous_9363 2 years ago
Red Belt
I've just had this exact same issue. It only occurs when the installation is run from a UNC share. I changed the deployment (not Altiris but the same principal applies, I think) to be copied locally first.

  • I gave this a try as suggested. Altered the script so it copies the install files to the target computer first and updated the location of the response file to point at the local copy. Still get the same error, just takes 5 minutes longer for the error to appear due to the large file copy process first. - morph1006 2 years ago
    • I ran into a few issues with our deployment -- what I had to do (I am doing a batch file) was for the RESPONSE.json file call, I did --in "\\dfsshare\location\response.json" to call from the DFS network share it was being deployed from. This fixed a lot of issues we were seeing. Not sure if that helps or not. - rirwinMSLC 2 years ago
Posted by: morph1006 2 years ago
White Belt

Top Answer

This issue was solved in the end by one of my colleagues.

It seems that the powershell script was setting command prompt to run from c:\ but the installer for visual studio was wanting to run from 'system 32'. He altered our deployment template to allow us to set command prompt back to 'system 32' and the installation the worked successfully.
Posted by: anonymous_9363 2 years ago
Red Belt
The other possibility - which has just come to me in a "light bulb" moment - is that the source path name is too long at some point.

By that I mean, if the source location's path name is in itself quite lengthy, the OS will stumble over the length of one of the paths further down the tree. I suspect this is why the installation examples show the files being copied to a folder in the root of the C: drive.

If this is the case for you, try using SUBST to create a drive from the path and then run the installation from the SUBSTed drive. I've had much success in the past using this kludge.
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ