/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Apologies if this has been answered elsewhere (I was not able to find it). I'm working on deploying Microsoft Lync 2010 in a mixed Windows environment (mostly XP, some Win 7 PC's). I can get it to go using the /install /silent switches under XP, but that does not work under Win7. No errors or anything pop up, it just doesn't do...anything. I tried running it locally just to make sure that I didn't miss anything within Kbox, and receive the same result (again, nothing).

Has anyone gotten this to deploy successfully (and silently) under Windows 7?

Any and all help is appreciated.
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Community Chosen Answer


Answers

3
The Lync installer contains an MSI. You're better off taking this and running it directly. It's how we did it here and it works fine. The MSI has a property USEMSIFORLYNCINSTALLATION which was set to 1.

Rgds,

PJ
Answered 10/06/2011 by: pjgeutjens
Red Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
And you might want to fix the Advertised Repair loop issue during launch, when using the MSI as stand-alone installer (check notes section).
Answered 10/06/2011 by: Matias M Andersen
Senior Yellow Belt

Please log in to comment
0
Forgive me for asking, but as someone pretty new to packaging (I was thrown into it, it's not my calling in life..lol) I am wondering about the reference to the setting USEMSIFORLYNCINSTALLATION. I looked at the MSI through Orca and found the setting, but how would you change this setting without a Transform? Would you not be changing the MSI itself? I have seen the error message received when trying to launch the MSI directly. I am also aware of the second executable OCSetupLauncher.exe which can be run with the switch /install /silent and it loads the prereqs and installs Lync.

But I am really wondering about changing the setting for the MSI.

Thank you for your patience.

KK
Answered 03/13/2012 by: Ksuekihlman
Senior Yellow Belt

Please log in to comment
1
To pass a public property to an msi just add it in the install command with the value you want.
msiexec /i <filename.msi> USEMSIFORLYNCINSTALLATION="#1"
Answered 03/13/2012 by: henrik80
Second Degree Blue Belt

Please log in to comment
0
Awesome! Thank you very much! Of course it would make sense that it is just that simple. I should have known the rule of KISS would apply! :)

This will obviously be valuable information for future reference.

Thanks again!
Answered 03/13/2012 by: Ksuekihlman
Senior Yellow Belt

Please log in to comment
1

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator]
"FirstRunLaunchMode"=dword:00000001

Answered 12/20/2012 by: jaybee96
Red Belt

Please log in to comment