/build/static/layout/Breadcrumb_cap_w.png

Registry keys not getting into HKCU

hi,
I got a problem with one application which I am working on.
I had an msi with 100 reg keys in HKCU and 10 reg keys in HKCR and 2 regkeys in HKLM.
After installing the MSI, i could see the reg keys in HKCU, HKCR and HKLM but when I logged in as another user i could not see HKCU and HKCR.
I also did active setup but still could not see.

Any suggestions would be appreciated.

Thanks
WEK

0 Comments   [ + ] Show comments

Answers (3)

Posted by: AngelD 12 years ago
Red Belt
0
By using HKCR the registry will either go into the HKCU for per-user install or HKLM for per-machine install, I guess you are doing a per-user right?
Set the ALLUSERS property to 1 for per-machine install.

Do you have any entrypoint to trigger a repair?
Posted by: WEK76V 12 years ago
Senior Yellow Belt
0
Thanks for the immidiate reply,
Yes I am doing Per-user and i donot have any entry point.
I tried different ways but still I could reproduce the same problem.

Thanks
WEK
Posted by: AngelD 12 years ago
Red Belt
0
Why not perform a repair triggered by the Active Setup then?
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ