/build/static/layout/Breadcrumb_cap_w.png

Register DLL

Hi,

I've captured a program which want to register some DLL's.
The MSI return a HRESULT -2147024769 error.

If I press ignore and try to launch to program, It sais it cannot be start because the DLL was not found.

Even if I try to register the DLL manually, I get an error

The DLL is loaded, but the DllRegisterServer entree point was not found
The DLL does not apear to be a .DLL of .OCX file

Can someone help me?

0 Comments   [ + ] Show comments

Answers (2)

Posted by: AngelD 14 years ago
Red Belt
0
If I press ignore and try to launch to program, It sais it cannot be start because the DLL was not found.Verify that the file is installed.
Is the DLL installed to the same directory as the application EXE file?
Does the original installation add to the path environment variable?

Even if I try to register the DLL manually, I get an error

The DLL is loaded, but the DllRegisterServer entree point was not found
The DLL does not apear to be a .DLL of .OCX file
If you can't register the DLL manual then it seems that It shouldn't be registered.
Posted by: aogilmor 14 years ago
9th Degree Black Belt
0
angeld you are correct - i have seen wise get this wrong a lot, you simply remove the offending dll from the selfreg table.
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ