/build/static/layout/Breadcrumb_cap_w.png

Quicktime hazzle

Hi!

I'm trying to deploy QuickTime 7.0.4 using SMS. This is what I've done:

1) Downloaded the quicktime-only setup from quicktime.apple.com (no itunes here!)
2) Extracted the contents
3) Made a transform which has the ISSETUPDRIVEN=1 property, a custom made preferences file I've made (QuickTime.qtp) and desktop shortcuts removed.

This works perfectly when done manually:

msiexec /i ISScript11.msi /qb
msiexec /i QuickTime.msi TRANSFORMS="mytransform.mst" /qr

...but when I import the package into SMS it doesn't work. The isscript installs well, but when SMS is trying to install QuickTime.msi it just fails without saying why. The event viewer just says "failed to install"...


This is how I'm trying to deploy the package:

I've made two SMS-programs, one for the ISScript package and one for the quicktime package. I've advertised the quicktime package, and I've set the isscript-sms-program as "run this program first" in the quicktime sms-program.

Logging:

Log part 1
Log part 2


Please advice! :-)

markus

0 Comments   [ + ] Show comments

Answers (1)

Posted by: KPrinz 14 years ago
Fourth Degree Green Belt
0
ORIGINAL: markuswalther

3) Made a transform which has the ISSETUPDRIVEN=1 property, a custom made preferences file I've made


I might be totally off key here, but when I did iTunes, I had to set ISSETUPDRIVEN=0 to get it to work.
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ