put files in System32 instead of SysWOW64

I have a application which has Printer Driver.The Files should go in C:\Windows\System32\spool\drivers\x64. but on Windows 7 64 bit the file is redirected to SysWOW64 where there is no spool\drivers\x64 folder .
Is their any way to redirect those files to C:\Windows\System32\spool\drivers\x64

Please advise me


0 Comments   [ + ] Show comments

Answers (3)

Posted by: jmcfadyen 12 years ago
5th Degree Black Belt
assuming this is an msi you could use a set directory CA on the appropriate folder.
Posted by: Gary 12 years ago
Blue Belt
No luck !

file is redirected to WOW directory.
MSDN say it can be done through disabling file redirection. but dont knw how to disable file redirection.

Posted by: anonymous_9363 12 years ago
Red Belt
This has to be done via an API call.

I think you may have the wrong driver for 64-bit operation as , from my reading anyway, only 32-bit files get redirected here.
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login


This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ