I have seen a lot of complaints for the same issue but no real solution so I thought I would ask...

We upgraded our Kace appliance to the 6.0 version from 5.4 and ever since, we haven't been able to deploy the Kace agent. Initially it was because for some reason now Windows 7 clients can't open the Samba share by using the FQDN so we changed that to the IP address instead but we are still having issues. See below:

[08/26/14 01:42:00 PM] Executing Windows platform provisioning.
[08/26/14 01:42:00 PM] Probing tcp ports for accessibility. 
[08/26/14 01:42:00 PM] Port 139 [netbios-ssn] open
[08/26/14 01:42:00 PM] Port 445 [microsoft-ds] open


 [08/26/14 01:42:54 PM] Executing remote communications:
 Initializing RPC
Connecting to ADMIN$
Copying service file
Disconnecting ADMIN$
Connecting to IPC$


Opening pipe to service
IN: pipe_open(\KBRemoteService, 7217006)
Sending commands
Commands: // client ampagent-6.0.1079-x86.msi KBox.mydomain.com
Sending login credentials
Login: ***\admin
[MSGCODE: 000] Begin agent_msi_provision.bat processing.
[MSGCODE: 032] Detected 32-bit platform.
[MSGCODE: 015] Executing MSI installer.

C:\Windows\TEMP>start /wait msiexec.exe /qn /l*v C:\Windows\TEMP\ampmsi.log /i \\\client\agent_provisioning\windows_platform\ampagent-6.0.1079-x86.msi HOST=KBox.mydomain.com

C:\Windows\TEMP>echo off
MSI Info: [ERROR_INSTALL_FAILURE] A fatal error occurred during installation.
Access is denied.
[MSGCODE: 002] K1000 Agent is not installed.
[MSGCODE: 092] AMP is not connected.
ERROR: The system was unable to find the specified registry key or value.
[MSGCODE: 095] KUID value not written by MSI installer.
[MSGCODE: 100] End agent_msi_provision.bat processing.
Removing service (Exit code: 0)
OpenService - NT_STATUS_OK
StopService - NT_STATUS_OK
DeleteService - NT_STATUS_OK
CloseServiceHandle - NT_STATUS_OK
Connecting to ADMIN$
Deleting service file
Disconnecting ADMIN$


[08/26/14 01:42:54 PM] End of remote communications. 
[08/26/14 01:42:54 PM] End provisioning run. 

I have made sure to turn off UAC on the PC I am testing with but still no luck. I've read something about a registry key to modify for UAC and might try that soon unless I get a better answer. We have over 500 PCs and having to modify a registry key on all of them just to make the Kace agent work is kind of crazy.

Thanks in advance
Answer Summary:
I just had the same issue. I moved the slider down and rebooted then it installed. now I re-enabled uac and all is good.
1 Comment   [ - ] Hide Comment


  • Hello all. I am currently having the exact same issue as detailed here. I tested by replicating the same issue on a computer I wanted to remotely provision.

    After I replicated the same error, I then proceeded to disable the UAC and then, without changing any settings on the provisioning screen in Kace, I ran the provision again and it succeeded. So disabling the UAC worked immediately for me. However, I cannot have it disabled in my environment.

    Is there a way around this? We did not have this issue with the earlier version of the Agent.
Please log in to comment

Answer this question or Comment on this question for clarity


Nothing is new about needing to disable UAC to install the KACE agent. It has been a requirement since Vista came out.  Microsoft has simply patched holes surrounding elevation of an account in recent months, and that's why you are seeing issues now.

A simpler answer might be to deploy the agent using Group Policy as it removes any installation requirement on the client machine itself (UAC, simple file sharing, printer and file sharing, etc):

Answered 08/31/2014 by: jknox
Red Belt

Please log in to comment
Hello if you would like to use local administrator account for provisionning, you use ".\Administrator" or "Administrator" in connexion id case ?

Answered 09/25/2014 by: gjoubert
Senior Purple Belt

Please log in to comment
I'm having the same issue.  It worked before the upgrade to 6.0.  After going to 6.0, I'm unable to see the samba share by name and I'm unable to install the agent via KACE provisioning.  Disabling UAC is not an option, we need it in our environment.

Installing each agent by manually entering in local admin credentials on each machine isn't a great option...  Installation by group policy works but only if there was no agent on the machine to begin with.  Once the agent is installed and removed on a machine, group policy never works again.

Our environment is completely broken as we are unable to install agents on our machines.  I've had 4 tickets open for this for months with no solution.
Answered 09/15/2014 by: edwimb
Third Degree Blue Belt

Please log in to comment
I'm able to deploy the agent by specifying the IP instead of the name of the K1000, and by providing local admin credentials on the machine it is being installed on.  To provide local admin credentials, I have to leave the domain field blank on the provisioning schedule detail screen (You have to do this as if you type in administrator and specify the domain, the install will try to run as your domain administrator account instead of the local machine administrator account).  After doing this the agent installs, but the agent will not check in and shows it as "Unable to reach this agent managed-device" in KACE.  This prevents me from being able to use the agent on that device even though it is installed.
Answered 09/22/2014 by: edwimb
Third Degree Blue Belt

Please log in to comment

  • Did you ever find a way around not having to disable UAC for the agent deployment to work?
    • We basically deployed a Group Policy to disable the UAC. Everyone in the organization had to reboot their computers at least once and some twice. After this, the agent was successful in it's installation. I believe also that retracting the policy you can again enable the UAC. Not the best solution but it's the only one we could come up with.
Please log in to comment

Ok, so I just did a test and attempted to deploy the agent by using local administrator account and the agent was successfully installed. I know the creds I used when installing it with my domain admin account are good otherwise it would have failed on step 2 I think with authentication FAILED (I tried an incorrect account just to see what it would do).

I think it might still be something related to UAC even though I brought the slider all the way to the bottom. I will try the registry hack I read about and see what happens but again having to do this now when everything was working good before V 6 does not make me very happy.
Answered 08/26/2014 by: raul102801
Orange Belt

Please log in to comment
I have the same problem after upgrade K1000 to V6. UAC block provisionnig, but for security i do not would like to disable UAC, have you an idea ?
Answered 08/28/2014 by: gjoubert
Senior Purple Belt

Please log in to comment
You can try deploying with Local Admin account instead of a Domain admin. I tried that and although it said it failed provisioning, when I checked the test PC it had installed it and the machine showed up in the inventory.
Answered 08/28/2014 by: raul102801
Orange Belt

Please log in to comment
This content is currently hidden from public view.
Reason: Removed by member request
For more information, visit our FAQ's.