/build/static/layout/Breadcrumb_cap_w.png
10/11/2018 108 views
Hi everyone,

We are just deploying Kace in our society and I'm facing a problem.
As some part of SMA are not up on our side, I wanted to create a new role for new user, without them seeing download section, and letting them only knowledge base and service desk tab.
I duplicated the default profile "user console only" removed the part I didn't want and set it as default profile for new user using the checkbox "Default role for new users".

I created an user for test, and logged into Kace, but the user, got the original user console only role.
I tried with other test account, and they all got the wrong role.
I checked multiple times on the role page and my custom role is tagged with [Default].
When I changed the role of utsers manually I don't get any issue, and they see what they are supposed to.

Can someone help me ?

Kind regards,
Ary
Answer Summary:
0 Comments   [ + ] Show comments

Comments


Answer Chosen by the Author

0
For all person who can face this issue :

Settings -> Control Panel -> Authentication settings -> expand the configuration LDAP browser and check that the role set is the correct role.

Answered 10/15/2018 by: Arystos
White Belt

All Answers

0
In your list of roles, there should be [Default] after your duplicated "user console only" role first off. 

Secondly, when you create a test account, part of the form already selects the the default role.  So if you really want, test this in an LDAP user imported environment.  See if the system adds them to the new default.  All existing accounts are going to already be set either by LDAP or manual as you are doing.
Answered 10/11/2018 by: worzie
Brown Belt

  • Thanks for your Answer Worzie, but We didn't imported users from LDAP, we connected Kace to our AD, and whenever a new user try to connect to kace, it creates his account.
    I assumed it would create his account with te default role.

    I Maybe made a mistake while configuring it.
    • Do your new users added in AD get this new default role set, just not displaying properly?
      • Sadly, no, they don't get the role tagged as default, but the user console only role.
        I even created another user, juste to be sure. but he doesn't get the proper role either.
        I think I'm good for another documentation reading session.
      • Looks like you may need to open a ticket with Quest then. It's working for me in 8x, so if you are 9x, it could very well be a bug I can't validate as me-too.
      • I solved it.
        The issue was from my Authentification settings, the users were getting another profile as it was still set to give the user console only.
        Now it works perfectly and each time a new user connects, he gets the correct profile.