/build/static/layout/Breadcrumb_cap_w.png
01/25/2017 1056 views
I am trying to install Jdeveloper 12c via SCCM and having major problems.
I have created a response file and have a batch file that copies it to the C:\ and then have tried both the exe version and the .jar versions of the Jdeveloper Studio with the following switches -silent -responseFile c:\jdevinstall     (jdevinstall is the responsefile I created)

It installs great, but the problem is SCCM changes the permissions of the install directory and wont allow users to run the program...
Is there a way to fix that via a script or a way to stop SCCM from doing that?

Thank you for any help.


 

Answer Summary:
0 Comments   [ + ] Show comments

Comments


Answer Chosen by the Author

0

Humm that's weird, I think the installer is rewriting the permissions not SCCM - SCCM doesn't do that sort of thing.

You should be able to script it, you can either use icacls (easy option) or use PowerShell (harder but native).

Icacls just works and is easy to find your way. PowerShell is super fidgety as you need to load the ACLS into an objext to apply to the folders, you can google that: http://www.tomsitpro.com/articles/powershell-manage-file-system-acl,2-837.html

You could get the ACL object from another folder and apply it the problem folder.

Good luck!

Answered 01/25/2017 by: rileyz
Red Belt

  • Thanks for the info. I tried the installer locally on a machine and it worked fine without the permissions problems. I had this problem before with SCCM and Visual Studio 2015 where two file permissions in the Default profile were changed and this caused any new user to not be able to log in. I found that out as others had that problem as well.I will have to look more into icacls to see if I can fix it, but for now I will just have to manually install the application.
    • Re: I tried this before"

      Did you install locally using the SYSTEM account though? Thats how sccm does its installs.

      icacls should do the trick (:
      • I took your advice and added an ICACLS line after the install and it seems to work. Thanks
      • Glad you got it sorted, easy win! (: