/bundles/itninjaweb/img/Breadcrumb_cap_w.png

Hi,

I am unable to disable updates in this application. I tried adding below registry keys in MST

[HKEY_LOCAL_MACHINE\Software\JavaSoft\Policy]
"EnableAutoUpdateCheck"=hex:0
"EnableJavaUpdate"=hex:0
"Frequency"=hex:10,d0,00,0
"NotifyDownload"=hex:0
"NotifyInstall"=hex:0
"UpdateSchedule"=hex:0

and adding properties 1. AUTOUPDATECHECK = 0, IEXPLORER = 1,JAVAUPDATE = 0, JU=0, MOZILLA = 1,SYSTRAY = 0 still I see "Check for Updates Automatically" option checked and "Update" tab available. Can anyone please let me know how to uncheck this option?

Many Thanks in Advance.

0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
Capture the registry keys (HKEY_CURRENT_USER\Software\JavaSoft\Java Update\Policy) after unchecking "Check for Automatic Updates" from your source installation and merge it to your package.

It worked for me.

Jeeoo!
Santro
Answered 08/10/2009 by: zipsantro
Purple Belt

Please log in to comment
0
i tried it, still not working.
Answered 08/10/2009 by: Manu77
Orange Senior Belt

Please log in to comment
0
We use a VBscript which will change the EnableJavaUpdate value to 1 after InstallFinalize
Answered 08/10/2009 by: rakesh.kumar
Senior Yellow Belt

Please log in to comment
0
Thank you for your responses,

Issue was MSI was overwriting registry values during installation. I wrote a custom action to write registry values at the end of the installation. Now it is working.

Thank you again..
Answered 08/10/2009 by: Manu77
Orange Senior Belt

Please log in to comment
0
There's no need for any of that nonsense. Search AD for 'deployment.properties' and 'deployment.config'.
Answered 08/10/2009 by: VBScab
Red Belt

Please log in to comment
0
Manu77, you are writing the keys at the wrong place. See the location and key of my work below.

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy]
"EnableJavaUpdate"=dword:00000000
"EnableAutoUpdateCheck"=dword:00000000
"NotifyDownload"=dword:00000001
"NotifyInstall"=dword:00000001
"Frequency"=dword:01020000
"UpdateSchedule"=dword:0000000e
Answered 08/10/2009 by: lam2070
Senior Yellow Belt

Please log in to comment
0
Until Sun learns how to use a public property, I'll only be trusting VBS to write the registry change.
Answered 08/10/2009 by: turbokitty
Sixth Degree Black Belt

Please log in to comment
0
Manu77, you are writing the keys at the wrong place. See the location and key of my work below.

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy]



yes, correct key is "HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy"


--------------
Manu
Answered 08/11/2009 by: Manu77
Orange Senior Belt

Please log in to comment
0
Hi ALL,
This is my first java application

I am trying with jre1.6.0_15 by creating mst.

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy
EnableJavaUpdate = thru registry.
and even set values JAVAUPDATE=0,AUTOUPDATECHECK=0;IEXPLORER=0,SYSTRAY=0;JU=0;

still its not able to disable UPDATE Tab Disable or disabling checkbox and also tried
with CA
strComputer = "."
Set StdOut = WScript.StdOut

Set oReg=GetObject("winmgmts:{impersonationLevel=impersonate}!\\" &_
strComputer & "\root\default:StdRegProv")

strKeyPath = "SOFTWARE\JavaSoft\Java Update\Policy"

strValueName = "EnableAutoUpdateCheck"
dwValue = 0
oReg.SetDWORDValue HKEY_LOCAL_MACHINE,strKeyPath,strValueName,dwValue

strValueName = "EnableJavaUpdate"
dwValue = 0
oReg.SetDWORDValue HKEY_LOCAL_MACHINE,strKeyPath,strValueName,dwValue

By Placing it in ALL Custom action ->Call vb script from embedded code -Normal Execute defered system/user context syncronous exit code.

thanks in Advance
Answered 09/10/2009 by: santosh.gornal@gmail
Yellow Belt

Please log in to comment
0
See post # 6.
Answered 09/10/2009 by: VBScab
Red Belt

Please log in to comment
0
This is what I deploy to all of the machines in our environment and no one gets any notifications of updates or anything...

I add both x86 and x64 changes for good measure!!!





: Disable Java Updates
: (x64)
reg add "HKLM\Software\Wow6432Node\JavaSoft\Java Update\Policy" /v EnableJavaUpdate /d "00000000" /t REG_DWORD /f
: (x86)
reg add "HKLM\Software\JavaSoft\Java Update\Policy" /v EnableJavaUpdate /d "00000000" /t REG_DWORD /f
Answered 03/20/2012 by: Cerbeos
White Belt

  • Thanks Cerbeos saved my day.........
Please log in to comment