/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Am wanting to deloy Java without the menu that comes up in Control panel.

Is there a way to stop it coming up? If not, how do I disable the buttons in the menu to not allow the user to be able to do updates.

Thanks in advance.

Am working with: jre-6u2-windows-i586-p
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
Hi Dan,
did you have a look here: http://itninja.com/link/bug-id:-6995830-x86-silent-install-fails-using-nt-authority\system-account-on-x64-vista/win7 ?

Regards, Nick
Answered 07/20/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
I did try all that was in the link above but still cant seem to keep the Java icon from appearing in Control Panel.
Answered 07/29/2007 by: dan0
Senior Yellow Belt

Please log in to comment
0
Never mind. Found the javacpl.cpl file that was the icon showing in Control Panel. added the registry line of: SOFTWARE\Microsoft\Windows\CurrentVersion\Control Panel\don't load\javacpl.cpl

So now when it installs it does not load the icon into Control Panel.
Answered 07/29/2007 by: dan0
Senior Yellow Belt

Please log in to comment
0
I agree with Dan0 but:

The other way can be by deleteing the CPL file. You will find it in

Windows\System32\J*.CPL

so u can write a custom action which deletes this file at the end of installation.
Answered 07/29/2007 by: sunny_sahdev
Senior Yellow Belt

Please log in to comment
0
going ahead with
SOFTWARE\Microsoft\Windows\CurrentVersion\Control Panel\don't load\javacpl.cpl
is better way i believe cos if u want to configure the app thru that shortcut then u can just remove the entry from "don't load"
Answered 07/29/2007 by: sunny_sahdev
Senior Yellow Belt

Please log in to comment