/bundles/itninjaweb/img/Breadcrumb_cap_w.png
HI!
I have a problem,i tride to install msi and needed also to show wht server,looks like that:
msiexec /i "program.msi" CP_Server=name
but it didnt work. any sugestions?
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
You can only specify public properties from the command line. public properties are easily recognised: they are in all upper-case. So, presuming that the property exists in the MSI's Property table and is indeed named in all upper-case, your command line needs to be:msiexec /i "program.msi" CP_SERVER=name
Answered 06/10/2009 by: VBScab
Red Belt

Please log in to comment
0
In order to pass properties on the command line (CP_Server in your case) they must be public properties - which must be all upper case - so CP_Server isn't a valid property.

I'm not sure if you can have underscores but you can try CP_SERVER=name on the command line, otherwise you'll have to check the documentation or preferably have a look in the property table of "program.msi" to find the correct property name...

Regards,
Rob.

Edit: Damn, you beat me to it!
Answered 06/10/2009 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
I allredy named in property that server like that,but may be,if i added two new registers,i maybe need to make two writes in property,but i know that i can put only one whith name like that so i confused
Answered 06/10/2009 by: lanselots
Fifth Degree Brown Belt

Please log in to comment
0
OK, it sounds like you want the contents of that property to be used in a couple of registry entries. Is that right?
Answered 06/10/2009 by: VBScab
Red Belt

Please log in to comment
0
in property manager i writed CP_server and server name,so it should use that name to configure the server but it dosnt
Answered 06/10/2009 by: lanselots
Fifth Degree Brown Belt

Please log in to comment
0
maybe i need to do something more
Answered 06/10/2009 by: lanselots
Fifth Degree Brown Belt

Please log in to comment
0
maybe i need to do something more Yes, you do. You need to write the property name in all upper-case! Your Property table entry would then look like this:

Property Value
====== ===
CP_SERVER whatever the name is goes here

Then, use the command line I posted earlier.
Answered 06/10/2009 by: VBScab
Red Belt

Please log in to comment
0
I allredy do that,only I put in value servername,and when i instaling i`m tying to write another server name but it dosnt work,so i know that that value dosnt mean anything,i just need to know when instaling server name,but it dosnt work:
msiexec /i "programm.msi" CP_Server=comp123
and after instalation it shows anyway my computer name,and if i try to install on another pc it shows that pc name
Answered 06/10/2009 by: lanselots
Fifth Degree Brown Belt

Please log in to comment
0
OK, so now it sounds like there is a Custom Action in the MSI which is setting that property to be the installing workstation's ComputerName. Search through the MSI in Orca or InstEdit (or whatever MSI-authoring tool you are using) for the string 'CP_Server'. I'll bet you find it in theInstallExecuteSequence table.
Answered 06/10/2009 by: VBScab
Red Belt

Please log in to comment