/bundles/itninjaweb/img/Breadcrumb_cap_w.png

Hi,Im making silent deployment of HP Support assistant. I took the msi, that the setup.exe extracts to temp, but when I install the msi silently, it does not add the taskbar icon "?", is there a way to add it manually? I found the switches for HSPF.exe /registertaskbar /showtaskbar, but they do not work when installed with only the msi.

0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Answer this question or Comment on this question for clarity

Answers

1

What is the sequence of your custom action and is it kept in ImmediateExecute or ExecuteDeferred? Also what type of custom action are you using?

Answered 08/20/2013 by: akki
Fourth Degree Black Belt

Please log in to comment
1

It could also be a feature that does the install of taskbar. Check Feature table and see if any of them have a Level above 100. Also check Property table and see what INSTALLLEVEL is set to... Any feature lower, will install, and higher will not install with out setting a condition.

Answered 08/20/2013 by: ekgcorp
Tenth Degree Black Belt

  • Anyone figure out how to extract the msi when it doesn't go to the temp file and also what the command line would look like?
Please log in to comment
0
Setup a Managed Installation in KACE with the EXE file Use associated file
HP-Support-Assistant-x.x.x.x.exe and use these Additional Parameters: /s /a /s /v" /qn"

The HP Support Assistant is silently installed and the taskbar icon is displayed.


Answered 03/22/2018 by: chneijens
White Belt

Please log in to comment