I how like to use my K1000 Go connect to k1000 appliance but in order to achieve this i would need some sort of public access to my company's private network.
1 Comment   [ - ] Hide Comment


  • I need this too. We have employees that travel or work remotely and connect to the internet but not our LAN/domain. The agent can't see the KACE appliance to report or be updated.
Please log in to comment

Answer this question or Comment on this question for clarity


You need to forward the ports 80/443 (if you use SSL or not) and 52230 (AMP connection) to the appliance.
Fix the Settings > Network Settings page, so the clients from outside the network can reach the webserver name.
If you have used an internal name (like kbox or kbox.company.local or whatever) you also need to change this on the clients.
Run a script which modify the agent settings 
Launch $(KACE_APP_DIR)\amptools.exe with params -resetconf host=external reachable address.
This obviously only affects clients which are checking in.

If you simply need to use K1000 Go, you only need to forward Ports 80 or 443
Answered 01/12/2016 by: Nico_K
Red Belt

Please log in to comment
If you want to make your K1000 available on Internet I'd recommend to buy an SSL certificate from a known CA (Verisign, Entrust, GoDaddy etc etc) and apply it to your K1000 before to publish it on internet.
If you have a wildcard certificate (e.g.: *.mydomain.com) you can use that as well for your appliances.
About the ports, as Nico_K already said, you need to allow at least these incoming connections towards your K1000: ports 80/tcp, 443/tcp  and 52230/tcp (if then you will switch completely to SSL you can even turn off 80/tcp).
In some cases you may need other ports as well if you use Replication or Alternate Locations for Managed Installations and your are pointing to a file repository on a SMB share.
The full list of ports needed by the K1000 can be found here:
Kind regards,
Marco - StockTrader  

Answered 01/13/2016 by: StockTrader
Red Belt

Please log in to comment