/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


Do not register typefile

11/26/2014 2221 views
I have captured an installation of an app that we use at work. When install the captured MSi i get a "could not register type library file..."
on a AF20.dll under common files\ESRI folder.

suggestions online say to change the file so it doesn't register. I am unable to find that option with MSI Editor.

Any suggestions?

0 Comments   [ + ] Show comments

Comments


All Answers

0
Have you checked the selfreg table?
Answered 12/01/2014 by: EdT
Red Belt

0
Thank you for your interest in PACE Suite and for your questions!

It is a well-known problem of Windows Installer. According to MSDN it is strongly advised against using the TypeLib table. Please, register type libraries using the Registry table.
Launch MSI Generator and go to Settings. Select your profile at MSI Creation Options and click Edit as shown on the screenshot:


Select Registry and uncheck the TypeLib checkbox:


Click the Save button and then re-build your package:


Inform us if it does not work for you.
Answered 12/12/2014 by: pace-support
2nd Degree Black Belt

This content is currently hidden from public view.
Reason: Removed by member request For more information, visit our FAQ's.
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ