I have an application, pretty old one which saves keyboard shortcut config files in the Application folder in Program files.

We use a locked down environment for standard users where they don’t have visibility and access to C drive. So for applications which requires an application folder access to modify to write stuffs we access user permissions from inside the package and it seems to work fine but for this application, its failing to point to the right location in the Application folder in Program files but instead pointing to the users profile folder, though the required folder has the required access for the users from inside the package.

For note: whenever I am logging in as admin in the same machine the application points to the right folder as defined in the package.

Any help with this?




0 Comments   [ - ] Hide Comments


Please log in to comment

Answer this question or Comment on this question for clarity



It sounds like the program is using a registry HKCU for each user. I'd search the registry for a specific location under one of the restricited users accounts you'll probably find the registry value there. Then change it to point to the correct registry.

Answered 10/25/2012 by: ms01ak
Tenth Degree Black Belt

  • Yea, I have found the location and made the change and also I am repairing this for all the users but, as soon as a standard user logs in this location is no more used by the application to save new configs.
Please log in to comment

ProcMon will show you *exactly* what's going on. Once you know that, you can alter the package to suit.

Answered 10/29/2012 by: VBScab
Red Belt

Please log in to comment

You don't mention your OS, but I'm guessing Vista/Windows 7 - I think this might be down to UAC Virtualization and it's use of the VirtualStore.

Search the internet around the topic and see if that helps - as a test if you turn off UAC altogether that should prevent the redirection and confirm that this is the issue/feature you're dealing with.



Answered 10/29/2012 by: dunnpy
Red Belt

Please log in to comment