/build/static/layout/Breadcrumb_cap_w.png

Adobe Reader 9

MSI package adjusted with Customization Wizard 9 installs perfectly. Opens, loads a local PDF.
When linking to a PDF in a browser (both IE and Firefox tested), it gives an error "The Adobe Acrobat/Reader that is running cannot be used to view PDF files in a web browser. Adobe Acrobat/Reader version 8 or 9 is required. Please exit and try again."
http://www.adobeforums.com/webx/.59b5b772/36 (adobe Forums post on the topic)

It seems that uninstalling, rebooting, reinstalling and doing the 'registration' will 'fix' the problem. However, asking people to do that on 3000 computers is not an option. Need to fix on install... or prevent from ever happening.

Any Ideas on how to do this? I've tried checking the registry differences, but no real success.

0 Comments   [ + ] Show comments

Answers (14)

Posted by: makelley 13 years ago
Senior Yellow Belt
0
I had the same issue. Re-create your transform and see if that works. I have noticed that if the transform is edited once it is generated this error shows. The other way around this is to unselect the box that says to open this in the browser. If this is unchecked the PDF will open in reader. I submitted the bug to adobe.
Posted by: graywalker 13 years ago
Senior Yellow Belt
0
I've re-created the transform twice already, deleting everything, re-downloading, re-unpacking the whole works.

Problem is that some of our .... yeah, thought it would be a good idea to use PDF forms that REQUIRE the browser to be used. Internal forms that send the filled out form on to another server or department or something.
Posted by: kiptek 13 years ago
Second Degree Green Belt
0
have you looked @ any orphan reg entries in HKLM\Software\Adobe left by the previous version? It could be finding a reg entry & reading the installed version from there hence the false positive... also check the %programfiles%\adobe fldr. i think i once had an issue where the v.7 reader left a stray activeX ctrl in here...
Posted by: graywalker 13 years ago
Senior Yellow Belt
0
No orphan registry entries, but MISSING entries.

I put these two entries in and BAM, it started working properly. Adding to the BMCCM (Marimba) package and testing how that works out. Think the path to the exe was the one that got it, but the other makes sure the EULA is listed as accepted.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Acrobat Reader\9.0\AdobeViewer]
"EULA"=dword:00000001
"Launched"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SOFTWARE\Adobe\Acrobat\Exe]
@="\"C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe\""
Posted by: Thegunner 13 years ago
Second Degree Green Belt
0
I must admit I have not come across anything like this while packaging this application.

All I did was to run the Exe, and when it gets to the stage of choosing the directory to install. Open Explorer and goto
C:\Documents and Settings\<Profile>\Local Settings\Temp
Copy the package, which will be a MSI and a Cab file and paste it in a different directory. Then all you need to do is to create
a MST and it should work a treat.
Posted by: kiptek 13 years ago
Second Degree Green Belt
0
that definitely would do it. i wonder why it did not put them down, though..?. Test the uninstall & see if u have to also provision for the removal of those reg entries... cheers!
Posted by: graywalker 13 years ago
Senior Yellow Belt
0
Thegunner, lots of other people HAVE had the problem, as indicated by the Adobe Forum posts. It is not in the packaging of Reader, it packages fine and installs fine and opens PDF files on the local machine just fine. It will not, however, open a PDF within the browser. So, unless you have thoroughly tested the install already, you may want to try clicking on a link to a PDF in a webbrowser and see if it opens in the browser. IE or Firefox either one. There is absolutely nothing wrong or out of place until you try to open a pdf within a browser.
Posted by: Thegunner 13 years ago
Second Degree Green Belt
0
Yep I know graywalker, dont have to go of the rails explaining it to me.
What I was saying was the process I did it and it worked. It opens in browses fine as well. Just tested it again, and it works.
All I was saying was the process I did and the outcome. If you dont want to follow that, then fine.
I wont bother explaining what I do in the future and let you figure it out.
Posted by: graywalker 13 years ago
Senior Yellow Belt
0
Thegunner, I did follow that procedure.... except NOSSO put the extracted files in "C:\Documents and Settings\<Profile>\Local Settings\Application Data\Adobe\Reader 9.0\Setup Files\" instead of the temp directory. (so, following your post, I wouldn't have found the .msi at all)
Copied the files from there to a new folder, used the Adobe customization wizard to create the MST.
Whether some option in there cause the error or it was something else, I don't know. I know many other people have had the problem running straight from the executable even.

Then used BMC's Application Packager to wrap the MSI and the Transform into a BMC CM (Marimba) package for distribution.

Is there another way to get the MSI? Is there another way to create the MST? If not, then my first post said that I'd already done that.

Something perhaps important that was missing is how you created the MST. I think there are probably other ways besides using the Adobe Customization Wizard. Some commercial re-packager program, but I don't have access to those. Also, what method did you use to distribute the package? Command Line? BMC? Microsoft's software distribution?
Posted by: Thegunner 13 years ago
Second Degree Green Belt
0
C:\Documents and Settings\\Local Settings\Application Data\Adobe\Reader 9.0\Setup Files\

Sorry my mistake it was this path, when I was writing the message yesterday i did it from the top of my head. And it didnt look correct when I posted the message.

I get the files from the above folder, then I copy them to another location.
From here I use Wise Talior to create the MST, go throught the options till the Talior stop. Then edit the MST and modify any shortcuts, files and information that you need to do. Then save and exit, then with the shortcut that gets created or you type in the START > RUN > msiexec /i "<PACKAGE>" /qn or add TRANSFORMS='MST" before the /qn to install it.

I have done the above on a few pc's for testing and seems to be working fine so far. Havent not got arouind to adding it to the server yet for deployment.

All the products I have been using are Wise, as we have WPS 7sp3.
Posted by: graywalker 13 years ago
Senior Yellow Belt
0
Now that is some great info. Thank you!

I wish the company would ante up for some good repackaging software, but we got a whole suite of BMC products (Configuration Management (formerly marimba), Remedy, Server Monitor, etc) and they don't really allow for much MSI customization, which is why I had to use the Adobe Customization Wizard 9 to do the MST with. Maybe I can use this as a point-for argument.

It does seem to be a bug in Adobe's installer, since it is quite widespread. I wonder what options actually cause it?
Posted by: gpenu 13 years ago
Yellow Belt
0
Thanks graywalker. They registry key that fixed my issues was the one below. I added that key and it works fine now. I edited my package with the Adobe Customization Wizard to add that reg key in the package. Works great now.

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SOFTWARE\Adobe\Acrobat\Exe]
@="\"C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe\""
Posted by: makelley 13 years ago
Senior Yellow Belt
0
[:@] All, that reg setting will fix reader. However, if you have Pro or Standard it will break those. If pro or std is installed you will have to change the path to point to the adobe apth "C:\Program Files\Adobe\Acrobat 8.0\Acrobat\Acrobat.exe"
I put a vbs in the the CA so that path was set.
Posted by: nheim 13 years ago
10th Degree Black Belt
0
Hi Mike,
this is only true, if you don't address this, when you install Acrobat Pro!
If you create an MST with the CW, you can set the default viewer either to PRO or Reader.
This affects this setting directly. You can do it by hand by setting the property "DEFAULT_VERB" to "Read".
Regards, Nick
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ