Hello


Most of our users need to access two or more shared mailboxes which are accessed through Outlook 2013. We are aware that there is the webmail route to access shared mailboxes but often this is extremely inconvenient - we would like to keep mailboxes in Outlook for easy access and transferring between inboxes.


When we add two larger shared mailboxes into outlook which carry more than a few thousand emails and a large amount of folders, the performance of Outlook will slow to a halt and then be continually unresponsive. This is especially the case when searching.

All machines in question are above 8GB RAM and a minimum of i5 processors. When looking at the performance of each machine while we wait for Outlook to come out of it's "not responding" state it is showing low CPU and RAM usage. Just to reiterate, this is on all machines and is not an isolated case.


All Office installs are done from the Microsoft 365 portal.

I've tried:

- Turning Cached exchange mode down from 12 months to 6 and then 3 months (seems to help for a while and then the performance issues return)

- Turning off cached exchange mode completely

- Turning off "download shared folders"

When we remove all shared folders everything then returns to normal.

Obviously we would expect Outlook to not run into performance issues like this especially when it's the latest iteration of the product.

I would appreciate an urgent response to this.

Many thanks

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1
Might want to look at the add-ins that are being loaded, if any.  Also make sure you are up to date with all the Office patches.  

We had issues with extreme slowness when someone had an added mailbox that no longer existed.  Example:  Employee A adds Employee B's mailbox.  Employee B leaves the company.  Employee B's mailbox is deleted from Exchange.  Employee A still has Employee B's mailbox in Outlook.  
Answered 07/09/2015 by: kalucas
Yellow Belt

Please log in to comment

Answers

-1
Maybe you'd want to try tagging your post properly first? This has nothing to do with 'Systems Deployment', 'Supporting Windows' or 'Cloud Computing'. Maybe add...ooooh, I don't know...'Outlook'? :-)

Try this on one of your machines, preferably not the MD's:

netsh interface tcp set global autotuninglevel=disabled
Answered 07/09/2015 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity