Has anyone been able to install Office communicator using the msi install file provided on the SP1 cd without logging on to a client machine as an administrator?
I have set up a GPO using the user configuration, software settings and published the msi but unless the user is a member of the local admin group on the client machine it fails. Has anyone else been able to get this to work without the elevated user rights?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Why not set the installer to use elevated rights in the GPO? does that work when the GPO is linked to users? Windows components\windows installer in the same GPO.
Answered 07/12/2006 by: elmurado
Senior Yellow Belt

Please log in to comment
0
hey out there. bit of a GPO noob here.

could really use some help getting office communicator 2005 installed over GPO as mentioned in this thread. i have set the 'elevated rights' setting in the GPO, but to no avail.

the most i have seen happen is a line appearing in the add/remove programs that shows 'Office Communicator 2005' - even though app is not installed. if i try to 'remove' that program, i get some fatal error.

something is just not right. do i need to modify the MSI file at all ?? I am using the one from the SP1 CD.

thanks much!
Answered 11/08/2006 by: gsonnad
Yellow Belt

Please log in to comment
0
I have solved the problem. I have found that by simply creating and setting permissions on one key in the registry, Communicator can be deployed via GPO assigned to users.

So here's the skivvy. I created the below script and set it up as a startup script in a gpo that applied to all computers. In the same GPO, I setup the permissions on the registry key to be full control for all users (the install creates one value in the key and that’s it).

Here's the script:

const HKEY_LOCAL_MACHINE = &H80000002

set oReg=GetObject("winmgmts:{impersonationLevel=impersonate}!\\.\root\default:StdRegProv")
strKeyPath = "SOFTWARE\Microsoft\Windows\CurrentVersion\Communicator"
oReg.CreateKey HKEY_LOCAL_MACHINE,strKeyPath


the key to set permissions on is:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Communicator

Hope this helps in the future.

-- Micah Rowland
Answered 03/31/2008 by: ioamnesia
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity