I am new to Kace but have been experimenting and setting it up for a few months. I have all my end-user computers (laptops only) in inventory and mostly ready to take over patching. Here's my problem. Let's say for example a patch job is running on one laptop to push 30 patches, in this example we turned off Windows updates with GPO:
  • The kbox pushes 10 of these patches but needs to reboot the computer before the job can continue
  • I assume it would display the reboot prompt agent pop up but it doesn't, it just sits there and waits
  • I need to manually reboot the computer
  • When it boots back up the patch job continues and installs more patches (if it's still in the scheduled time window; if not, suspended)
  • It then sits there again and I must manually reboot. Only when the kbox pushes the last batch of patches and needs a reboot does it display the agent pop up.
Now I turned off the Windows Updates GPO, when a batch of patches is pushed and Kace needs the computer to reboot, I get the usual Windows Updates reboot prompt. No reboot prompt agent pop up. Still I get the agent pop up with Windows Updates enabled only when the final batch of patches is pushed. 

I have a case open with Kace support. Am I missing something?

Thanks all,
3 Comments   [ + ] Show Comments


  • What are your settings for the patching schedule? Is it a Detect and Deploy schedule? What are the reboot prompt settings?
  • Hi Chuck. I've updated my initial question with screenshots of the patch job. It seems to not matter what settings are present at the time. I do get the initial agent prompt, just never the reboot agent prompt until the very end. Thanks for taking a look at my post.
    • Have you tried setting the timeouts to a longer period? I have mine set to 10 minutes.
  • Chucksteel, I've tried all different settings and options regarding times. I believe the solution is the one I've listed in the answer section below. What is your experience with syntax in the reboot prompts?
Please log in to comment


I think we found the issue which was causing random and unexpected behavior with the reboot agent prompt. Support found a kb article from 6.2, probably before, which says the reboot prompt does not support new lines, or carriage returns. Even dumber is the bug did not mention that any of the Notify messages do not support new lines. This seems to have been causing extremely delayed or in my case indefinitely delayed reboot prompts, until the very last batch of patches. However this last reboot prompt did display the new lines, doesn't make sense. I was also getting a black bar below the message in the agent prompt on most Dell laptops which I think I am not getting anymore by not having new lines. This is such a dumb feature that isn't supported, I should be able to make my reboot prompt look like anything.

If anybody can share what their reboot prompt messages look like and if they've had any similar difficulty I would greatly appreciate it.
Answered 03/26/2015 by: bens401
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity
Nine Simple (but Critical) Tips for Effective Patch Management
This paper reviews nine simple tips that can make patch management simpler, more effective and less expensive.