Hello,

Just curious if there are any users out there utilizing Google Apps - Premier Edition and the KBOX 1100? Just wondering how you configured SMTP to work with your KBOX 1100. I know Google uses SMTP, but it doesn't use Port 25. It requires authentication and uses SSL.

ZT
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Try port 465.

http://mail.google.com/support/bin/answer.py?hl=en&answer=13287
Answered 04/13/2010 by: airwolf
Tenth Degree Black Belt

Please log in to comment
0
The problem is that the KBOX can't be configured to use 465 for outgoing email OOB.
Answered 04/14/2010 by: jkatkace
Purple Belt

Please log in to comment
1
We use google apps too and have just got the kbox, this is what I did:
One thing is that you use SMTP not POP, as you are using premium you can fwd emails sent to particular email address to an SMTP server (http://www.google.com/support/a/bin/answer.py?answer=175745).

on my firewall I set an SMTP route for the kbox in and out. (SMTP only - you should set the route to only allow from google)
then I crated a new DNS entry for the kbox using the NAT address set on the firewall (kbox.domain.com) (just an A record not an MX record as google will still receive the messages)
I think by default the kbox will be an SMTP server.

Google apps you can set an alternate email route for each email address, I created servicedesk@domain.com and removed all existing routes and added and new one servicedesk@kbox.domain.com now and set the Change SMTP envelope option to true. This tells google to route all emails sent to servicedesk@domain.com to servicedesk@kbox.domain.com. Then kbox takes over.

No problems so far running like this for a week now.
If anything is not clear let me know, I will try and explain a little better.
Keep safe
Matt
Answered 08/22/2010 by: berrym
Yellow Belt

  • am I correct in saying that the Kbox has it's own SMTP server? so anymail routed to its ip will get queued?
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
Please log in to comment
0
I like berrym's approach, and may implement that later. When we migrated to Google Apps, we ran into the nasty surprise of a lot of legacy apps & devices not being able to send with credentials or via a different port....so I had to setup a Virtual SMTP service on one of our win servers (behind a firewall, of course) to act as a relay. All of these apps & devices send emails to the Virtual SMTP...it then relays all of that email with credentials (we used do.not.reply@domain.com) through Google Apps. Since this was already setup, I pointed the Kbox to send through this same SMTP relay. This only works for outgoing emails at this point, so I might be following berrym's instructions if setting up outgoing emails to servicedesk.
Answered 09/20/2010 by: badamson
Senior Yellow Belt

Please log in to comment
0
Thanks Berrym. We implemented your solution today and it's working well for us.
Answered 01/05/2011 by: van.k.jones
Orange Belt

Please log in to comment
0
I have a few questions, if I may...

I am able to successfully email my KBox and it does what it is supposed to (auto create a ticket). My problem is getting emails from my KBox. My outgoing emails never arrive to my desired recipient. Any ideas on where to start troubleshooting? I have checked SPAM, etc. I think it is a setting in the KBox.

Should I not point the SMTP traffic to smtp.google.com? If I uncheck that box does it automatically use it's own SMTP server?
Answered 05/03/2011 by: ScottinOkla
Orange Belt

Please log in to comment
0
Bump...
Answered 05/05/2011 by: ScottinOkla
Orange Belt

Please log in to comment
0
Ok after many hours of scouring the internet, and most of it leading right back to this forum, I have found the troubleshooting page inside KBox. Upon running the troubleshooting I have this log file:

Domain names and usernames have been changed to protect the innocent [:)]


LOG: MAIN
<= support@k1000.mydomain.com U=www P=local S=414
delivering 1QIKik-0005JN-Gz
Connecting to gmail-smtp-msa.l.google.com [74.125.95.109]:25 ... connected
SMTP<< 220 mx.google.com ESMTP f7sm1340125ibn.58
SMTP>> EHLO k1000.mydomain.com
SMTP<< 250-mx.google.com at your service, [164.58.170.218]
250-SIZE 35882577
250-8BITMIME
250-STARTTLS
250 ENHANCEDSTATUSCODES
SMTP>> STARTTLS
SMTP<< 220 2.0.0 Ready to start TLS
SMTP>> EHLO k1000.mydomain.com
SMTP<< 250-mx.google.com at your service, [164.58.170.218]
250-SIZE 35882577
250-8BITMIME
250-AUTH LOGIN PLAIN XOAUTH
250 ENHANCEDSTATUSCODES
SMTP>> MAIL FROM:<support@k1000.mydomain.com> SIZE=1448
SMTP<< 530-5.5.1 Authentication Required. Learn more at
530 5.5.1 http://mail.google.com/support/bin/answer.py?answer=14257 f7sm1340125ibn.58
SMTP>> QUIT
LOG: MAIN
** username@mydomain.com R=smart_route T=remote_smtp: SMTP error from remote mail server after MAIL FROM:<support@k1000.mydomain.com> SIZE=1448: host gmail-smtp-msa.l.google.com [74.125.95.109]: 530-5.5.1 Authentication Required. Learn more at\n530 5.5.1 http://mail.google.com/support/bin/answer.py?answer=14257 f7sm1340125ibn.58
LOG: MAIN
<= <> R=1QIKik-0005JN-Gz U=mailnull P=local S=1532
delivering 1QIKik-0005JQ-Vf
LOG: MAIN
Completed
LOG: MAIN
=> support <support@k1000.mydomain.com> R=helpdesk T=helpdesk_pipe
LOG: MAIN
Completed


I have double and triple checked that I have the smtp.gmail.com feature turned OFF, unchecked and removed the value. Who can help me understand what is happening and going wrong in this log file?
Answered 05/06/2011 by: ScottinOkla
Orange Belt

  • Currently the K1000 does not support SMTP authentication using TLS/STARTTLS port 587 or SSL port 465. So you will need to setup an internal SMTP server that can provide SMTP authentication to relay outgoing email from the K1 to hosted email servers like Google or Exchange 365.

    To retrieve emails from these email servers, you need to use version 5.4 on the K1 since it will allow POP3 with SSL to pull down email to the K1.

    A future version of the K1 will have support for SMTP authentication.
Please log in to comment
0
Please contact support.
Answered 05/10/2011 by: cblake
Red Belt

Please log in to comment

Please log in to comment
Answer this question or Comment on this question for clarity