I need to enable Java (1.6.0_20) for Mozilla browsers.

I know this can be done during install of Java or through the console (as admin) if already installed.

  • I've tried editing the value of [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6.0_20\MSI\MOZILLA] from 0 to 1. This is not enough.
  • Also tried adding the value [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Plug-in\1.6.0_20\MOZILLA] = 1, Also not working.
  • Tried a combination of the above, without success.

I know I can solve the problem by reinstalling Java, but this is not an option atm.

Thanks in advance!

EDIT: I've also done a snapshot of what happens when I change this in the console, but doesn't find anything in that either

Answer Summary:
I've considered myself beaten by Oracle, and did a re-install of Java with the "MOZILLA=1" property.
0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


I think this setting is saved in one of the preference files for the browser. Using a snapshotting tool, change this setting and see if one of the .js files on the machine changes. For the version of Firefox I have installed here (11.0) I think it's in the file C:\Program Files\Mozilla Firefox\greprefs.js, but I think this was different for older versions.

Anyway, once you've identified the correct file, you could modify these settings through scripting.


Answered 04/26/2012 by: pjgeutjens
Red Belt

  • Thanks for the feedback PJ, but it's actually not what I'm after here.
    I need a "fix" which enables Java for Mozilla family browsers. See the print screen above. I want the checkbox to be checked and I can't for my life figure out how to. =(
    Edit: The original package installation was done not to enable support for Mozilla.
  • ah, my bad
    Have you tried setting
    deployment.browser.vm.mozilla = true
    in the deployment.properties file of your java installation?
  • No worries.

    I tried the deployment.properties hack also, but was unsuccesful.
    However, I was changing the file located in the user profile, but I guess I need to change a global deployment.properties file. I can't find any though. =/
    I was hoping for a -Xusage command, but no.
  • a system-wide deployment.properties file goes into C:\Windows\Sun\Java\Deployment\deployment.config or $Java Home$\lib\deployment.config
    It's entirely possible it's not there and you need to put it there yourself. If the hack does not work for the file in the user profile though, I'm not sure if it will work at all...
Please log in to comment


Maybe you only installed 64-bit java on a 64-bit system. For Windows, there is only 32-bit Firefox, so it needs 32-bit java.
Answered 08/22/2014 by: AshkanV
White Belt

Please log in to comment

Check this post for Firefox.


and change this setting in your machine and see what value is added in Mozilla.cfg file and then you can add that in your package.

Answered 04/26/2012 by: piyushnasa
Red Belt

  • That didn't really help me Piyush.
    I've already managed to package Firefox, that's not the issue here. The issue is purely Java related and how to enable checkbox for the Mozilla family in the console.
Please log in to comment
Answer this question or Comment on this question for clarity