/build/static/layout/Breadcrumb_cap_w.png

Work Perfect Office 12 Run As Admin Issue

Hi Guys,

Yet another interesting issue that i had came across.For an application named Work Perfect Office 12 there is a shortcut named Clip Manager which points towards an exe named clipbook.exe.the application has been sequenced and during the testing of this application i noticed that the shortcut which i had mentioned above doesnt work on Standard user.The OS we were testing on was Win7(32 and 64 biy both).It needs a Run As Admin Shim in order to work.
Has anyone faced this issue.I had taken the prcoessmon too but that didnot help.I believe the Run As Admin shim is not a feasable option.
Please enlighten..

0 Comments   [ + ] Show comments

Answers (5)

Posted by: Rheuvel 11 years ago
Brown Belt
0
Hi AJ,

I have never been confronted with Word Perfect (it's about Corel Word Perfect, I assume??) yet. Could you tell me some more about this?

How does it behave with an out of the box install? So, if you install it manually without the sequencer...
Does it give the UAC prompt or it just doesn't work as a restricted user?

Also, I just read a bit about the Clipbook... It sounds like some nasty app.


Copying an Item to a Clip
When the Clipbook is running, the shortcut keys for cutting (Ctrl + X) and copying (Ctrl + C) are reassigned — they now open the Clipbook window, where you can label and save the item. This can be a bit tricky if you're accustomed to using the default Windows shortcut keys for copying and pasting. Later in this tutorial, I'll show you how to select a different set of shortcut keys for the Clipbook

Source: http://www.corel.com/servlet/Satellite/us/en/Content/1153321168430

The Windows clipbook runs a service for example. Does it try to interfere with that? Does the Corel Clipbook maybe have it's own service?


By determining what exactly is causing the problem we can maybe figure out if it's something that can be solved at all with App-V.
Posted by: ajchak 11 years ago
Orange Belt
0
Hi..

The source is working fine i suppose...i checked the source behavior in Win7 its working properly in standard user and hence it should be a problem with the sequence :(:(
Neways although i did solve the problem....there were some junk registry keys that were captured and hence i removed them and along with that some settings were captured too...
These were responsible for this behavior i suppose
Posted by: Rheuvel 11 years ago
Brown Belt
0
So, is it working now?
Posted by: ajchak 11 years ago
Orange Belt
0
Hi,

Ya problem solved....actually when we launch the shortcut exe during Monitoring Phase...it captures some HKCU registry settings which has hard coded user profile references and as a result this was not working in standard user as the application was captured in a Build using a admin profile account.
The issue is solved.....now.................
Posted by: Rheuvel 11 years ago
Brown Belt
0
OK, good to hear!

I've linked this thread to the Package KB for future reference [;)]
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ