/build/static/layout/Breadcrumb_cap_w.png

Need a way to disable Java Update Checker from popping up this prompt from initially popping up.


2 Comments   [ + ] Show comments
  • Try to add
    deployment.expiration.check.enabled=false
    deployment.insecure.jres=NEVER
    In C:\WINDOWS\sun\java\deployment\deployment.properties
    And delete the user specific property file.
    C:\Users\%USERNAME%\AppData\LocalLow\Sun\Java\Deployment\deployment.properties - wmrofri 6 years ago
    • That will work, but it will still display the first time after installing Java. Until Java runs, and reads that file. You can call the Java control panel at the end of your script and close it. Which will cause Java to read that file.

      I solved this by just adding a registry GPO.

      [HKEY_CURRENT_USER\Software\AppDataLow\Software\JavaSoft\DeploymentProperties]
      "deployment.expiration.check.enabled"="false" - dugullett 6 years ago
      • Nice solution, where did you find that? I have read the JAVA deployment guide and I can't recall they mention any registry keys.
        Anyway, thanks for sharing... - wmrofri 6 years ago
      • That deployment.properties file populates those keys. It just takes Java launching to read that file. Once it's there it will never prompt again. I just got done doing a Java deployment so it's still fresh in my mind. It was a combination of different forum posts. I do not remember the specific one at the moment.

        I'm using a combination of the deployment.properties file, and this GPO. - dugullett 6 years ago
  • Good Deal.. thanks fellas. - Jamaica25 6 years ago

Answers (1)

Posted by: Guttormr1 6 years ago
Senior Yellow Belt
0

If you've upgraded to Java 1.7.0_51 or later...you typically don't see this prompt anymore, you just get blocked.

If you are just looking for a personal fix...you can look in your profile C:\Users\<username>\AppData\LocalLow\Sun\Java\Deployment\deployment.properties

This file controls Java version checking...i believe you need the line:

deployment.expiration.check.enabled=false

But once you are on version/update 51 or later...you may lose your option to run "later" so you might have to add the sites url to the site exception list introduced in update 51.

Open Java Control Panel, Security Tab, Edit Site List... (this button is only available after update 51 is installed and the file by default is stored in the users profile)

 

Click the Add button, Enter url into available slot, click ok.

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ