/build/static/layout/Breadcrumb_cap_w.png
11/29/2018 704 views

Migrated from on-prem exchange to O365.  Kace K1000 and K2000 emails from a default email address.  K1000 uses reporter@[system name][domain] while k2000 uses root@[system name]

When it was on-prem, we could use any from email address of any domain, but with O365 it requires the accepted domains to be used.  Where can the from email address be changed so it can work again.  If we cannot change it, we will not be able to be emailed reports and alerts because the domain is not an email domain that we can use.

Has anyone been able to get it to work?

Thanks,

0 Comments   [ + ] Show comments

Comments


All Answers

0

I'm afraid that is not possible, those addresses are coded with the EXIM server of the KACE appliance:

https://kace.uservoice.com/forums/82699-sma-k1000/suggestions/8189190-change-the-reporter-email-address

I have seen other appliances with O365 and GMAIL accounts using reporting just fine, maybe add some MX records.


NOW, if you go to Settings > Network Settings and Email Configuration, if there is an email(login) and a password there, the BOX will attempt to use those instead of root and reporter addresses.  (This is only true for the KACE SMA, the SDA doesn't have a way to send email reports, and daily ones will be sent via root).

 

Answered 11/30/2018 by: Channeler
Red Belt

  • That only works if you have one queue, right? We have several and therefore have several helpdesk email addresses. We had scheduled reports that would create monthly tickets and the rule to auto assign them was based on the email address for that queue. So we can't use this for all of our scheduled tickets.
    • I don't think that is possible with stock tools...

      You could write up a powerful SQL custom ticket Rule to achieve this... but is not 101 stuff, see:

      https://www.itninja.com/question/how-do-you-set-up-custom-ticket-rules-to-send-an-email-to-a-different-technician

      https://www.itninja.com/question/how-do-i-create-a-ticket-rule-to-email-a-particular-technician-when-a-user-selects-a-location-in-a-custom-field
0

When we migrated from our on-prem Exchange server to G Suite/Gmail we ran into the same issue. But I'm not sure if our solution will work for O365.


Since KACE uses SMTP for it's email we had to use a few steps to get it to send and receive emails. 

  1. We created a fully provisioned user account in Active Directory and Gmail 
    1. The A/D user has no access other than "Domain User"
    2. The password is set to never expire and is a randomly generated password that is very complex.
  2. We created a special organizational unit in G Suite called "Service Accounts"
    1. The configuration of the G Suite O/U was adjusted to allow POP/SMTP
    2. The user account was also setup to enable the use of POP/SMTP
  3. We then used that account and password in the SMTP configuration of KACE to send and receive email.

We went with this configuration as our K1000 does allow for incoming email to create help desk tickets.


Answered 01/02/2019 by: dsteinhauser
Senior White Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share