How do you trigger a script to run, within your MSI on repair of that MSI? I thought the syntax was:
If ReinstallRepair = "ALL" then

But this does not trigger the wise script.

Any thoughts?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
The syntaxt is "Installed and NOT Remove" to run custom actions on repair
Answered 11/17/2004 by: scorpianfrog
Senior Yellow Belt

Please log in to comment
0
Try using REINSTALL MODE-AMUS
Answered 02/18/2005 by: strakm
Senior Yellow Belt

Please log in to comment
0
@strakm - I believe scorpianfrig was talking about conditional statements on a Custom Action.
Answered 02/21/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
Hi I aslo have a similar problem where my shortcut is not updated. I have a custom action which modifies the shortcut but on a repair it does not modify it.


Thanks,
Afroz
Answered 03/08/2005 by: afkvrts
Yellow Belt

Please log in to comment
0
If you are running the script via a custom action, i think putting the condition as installed will only execute the custom action when the self repair is trigged in which the appliction is already installed.
Answered 04/10/2005 by: mohd
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity
Admin Script Editor
Admin Script Editor is an integrated scripting environment available free here at ITNinja

Share