I have created an install package for a software called Autodesk DWF Viewer using Wise Package Studio 5. The package is small and fairly simple. When installing and uninstalling the package using Windows Install 2.0 everything is fine. When I upgrade to Windows Installer 3.1, installation of the package is fine, uninstalling however is the problem. I do the uninstall from the Add\Remove Programs in Control Panel. I click on the Change button for this package and choose Remove so I can watch the package in action. What I see is unusual: The un-installaton never hangs, however it gets bogged down removing registry keys. There are a lot of registry keys in HKEY_CLASSES_ROOT for this package. The CPU is pegged at 99 % (all Msiexec.exe) and the time in the un-install screen shows more than 40 minutes! (and climbing!). This package is only about 8mb. If I remove Windows Installer 3.1 and revert back to Windows Installer 2.0, the problem goes away. It then takes only about 20 seconds to un-install this package. Has anyone seen this problem? I am running this test on a machine running Windows XP SP1 and all the latest patches as of Tuesday Sept. 21 2005. I have also run this same test in a VMWare session where I installed Windows Installer 3.1 only (not any other patches) on Windows XP /w SP1, and I still have this problem.
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


I am having the same problem. Did you find a solution?


Answered 11/16/2005 by: Kiemo
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity