I'm starting my Windows 8 deployment experimentations and am off to a poor start.  I've uploaded the Dell OEM Windows 8 media to my K2 and have created a simple scripted installation for Windows 8.  The installation starts but fails right away with error "Windows cannot locate the disk and partition specified in the unattended answer files <ImageInstall> setting."  I checked the answer file and that setting is set as "<InstallToAvailablePartition>true</InstallToAvailablePartition>".  I am using the included "Create UEFI partitons" pre-task and have verfied the existance of the C drive.  I don't understand why this install fails.

I'm new to Windows 8 but have plenty of experience with the K2000 and Windows XP/7 installs.  Has anyone else created a Windows 8 scripted install and can provide some pointers?

Answer Summary:
The kbox does not support direct UEFI booting. You need to create UEFI boot stick and set your bios to UEFI mode on the target machine.
Cancel
4 Comments   [ + ] Show Comments

Comments

  • What is the size of your C: drive? That error could mean that the partition isn't big enough.
  • This is a 320 GB disk. The Kace provided pre-task formats the hard drive with one 200 MB FAT32 partition and the remaining is formatted as NTFS. I have examined the partitions after the install fails and the volumes are formatted correctly.
    • I have resolved something similar to this on a UEFI system by running DISKPART and doing a clean format of the entire drive prior to running the scripted install. I can't think of what else to have you try, except for another machine entirely.
      • I tried that too before posting. I'm used to troubleshooting install issues with Kace but this is my first attempt with Windows 8 and UEFI.
    • It does sound like you're doing everything correctly. I've done a Win8 scripted install with the "Create UEFI partitions" preinstall task successfully so I know it works out of the box. If it were me I would try a different drive next, or see it works without the UEFI preinstall task.
  • jegolf, this is a Latitue E5430 that comes preinstalled with Windows 8. UEFI is enabled from the factory.
  • Windows 8.1 is not yet supported on the K2000. From what I understand version 3.6 will support it which is due to release during the first quarter of 2014.
    • I'm doing 8.1 scripted installs and images right now on 3.5.
Please log in to comment

Community Chosen Answer

2

to create uefi boot

from the k2000: check create usb on and download

unzip to tech station

run the installer and choose fat/uefi

with the boot stick in your target machine, set the bios drive settings from legacy to uefi and you should be be to see the stick.  boot it and deploy your uefi scripted install

Answered 12/12/2013 by: SMal.tmcc
Red Belt

  • Yes! This is it. I didn't know I would have to boot from a USB stick to deploy Windows 8. I think the original problem was Windows trying to install to a UEFI system but like you said, Kace doesn't support it so the install couldn't see the disk. My install is making progress now and I expect it to finish. Thanks!
    • your winpe was in legacy mode when booting via pxe and had no uefi drivers loaded was why that occured
      • I am currently imaging Windows 8.1 without a usb stick because it is not UEFI. Thus why I say, UEFI needs the usb stick, not the OS itself. Maybe it is just semantics, but I wanted to clarify in case he was confused.
      • Yea, it comes down to the kbox does not advertise the proper components UEFI enabled bios needs to recognize it as a bootable device.
    • Just to clarify, you don't need a usb stick to deploy Windows 8 per se, just UEFI.
      • oh you need a stick. The startnet.cmd maps you to the kbox
        even with windows 7 uefi you needed a win 7 uefi boot stick.

        most image systems are just getting on to the uefi booting, it is different in the way it loads the drive system, legacy looked for a boot sector where uefi looks for a file. in bios you can browse for that file on a fat32 partition and choose it to boot with.
      • the rule here is the bios needs to be in uefi prior to booting so winpe loads the drives in uefi mode.
Please log in to comment

Answers

1

Hy guys, i've modifed default CREATE UEFI PARTITIONS script down below:

select volume 1 instead previous "select disk 0"
Clean
Convert gpt
Create partition efi size=200
Assign letter=s
Format quick fs=FAT32
Create partition msr size=128
Create partition primary
Assign letter=c
Format quick fs=NTFS
Exit

After that, I no longer had error "Windows cannot locate disk....... etc... ".

You first have to list you partitons to see which one is "main" for Windows... and select that volume for script to use it.

 

Edit: with "Apply UEFI partitions" task i got error that mid-installation task failed... BUT, windows 8 installation continued normally after restart... so when I read description of mentioned task it said that its used for "imaging", not for SI... so there you go guys, hope it helps...

Edit: work normaly without that "apply uefi partitions" task.

"Windows cannot locate the disk and partition specified in the unattended answer files setting." - See more at: http://www.itninja.com/question/windows-8-scripted-installation-with-k2000#sthash.CJPHhzFw.dpuf
"Windows cannot locate the disk and partition specified in the unattended answer files setting." - See more at: http://www.itninja.com/question/windows-8-scripted-installation-with-k2000#sthash.CJPHhzFw.dpuf
"Windows cannot locate the disk and partition specified in the unattended answer files setting." - See more at: http://www.itninja.com/question/windows-8-scripted-installation-with-k2000#sthash.CJPHhzFw.dpuf
"Windows cannot locate the disk and partition specified in the unattended answer files setting." - See more at: http://www.itninja.com/question/windows-8-scripted-installation-with-k2000#sthash.CJPHhzFw.dpuf
Answered 12/19/2013 by: dlistar
Second Degree Blue Belt

Please log in to comment
This content is currently hidden from public view.
Reason: Removed by member request
For more information, visit our FAQ's.

0

I haven't played with UEFI much just yet but do you have it enabled in the BIOS of the system you are imaging?

Answered 12/12/2013 by: jegolf
Red Belt

Please log in to comment
0

My windows 8.1 scripts work fine.  Could be that you are using a oem disk.

 

Answered 12/12/2013 by: SMal.tmcc
Red Belt

  • Interesting, I couldn't get a SI to work with the Apply UEFI mid-level task. I thought that was only for images, not SI's. Without that task my SI works fine.
    • don't know what to say, the last mod I did 6 months ago was to change admin pw in script. here is the script from uefi install

      <?xml version="1.0" encoding="utf-8"?>
      <unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <settings pass="windowsPE">
      <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <UseConfigurationSet>true</UseConfigurationSet>
      <UserData>
      <AcceptEula>true</AcceptEula>
      <FullName>TMCC</FullName>
      <Organization>ITO</Organization>
      </UserData>
      <ImageInstall>
      <OSImage>
      <InstallToAvailablePartition>true</InstallToAvailablePartition>
      </OSImage>
      </ImageInstall>
      </component>
      <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <UILanguage>en-US</UILanguage>
      <SetupUILanguage>
      <UILanguage>en-US</UILanguage>
      </SetupUILanguage>
      <InputLocale>en-us</InputLocale>
      <SystemLocale>en-us</SystemLocale>
      <UserLocale>en-us</UserLocale>
      </component>
      </settings>
      <settings pass="specialize">
      <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <RegisteredOwner>TMCC</RegisteredOwner>
      <RegisteredOrganization>ITO</RegisteredOrganization>
      <TimeZone>Pacific Standard Time</TimeZone>
      <AutoLogon>
      <Enabled>true</Enabled>
      <Username>Dfault</Username>
      <Password>
      <PlainText>true</PlainText>
      <Value>password</Value>
      </Password>
      <LogonCount>2</LogonCount>
      </AutoLogon>
      <ComputerName>*</ComputerName>
      </component>
      <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <Identification>
      <JoinWorkgroup>tmccadmn</JoinWorkgroup>
      </Identification>
      </component>
      <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <RunSynchronous>
      <RunSynchronousCommand wcm:action="add">
      <Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
      <Description>Setting Network Location</Description>
      <Order>1</Order>
      <WillReboot>OnRequest</WillReboot>
      </RunSynchronousCommand>
      </RunSynchronous>
      </component>
      </settings>
      <settings pass="oobeSystem">
      <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <OOBE>
      <HideEULAPage>true</HideEULAPage>
      <NetworkLocation>Work</NetworkLocation>
      <SkipMachineOOBE>false</SkipMachineOOBE>
      <SkipUserOOBE>false</SkipUserOOBE>
      <ProtectYourPC>1</ProtectYourPC>
      </OOBE>
      <UserAccounts>
      <LocalAccounts>
      <LocalAccount wcm:action="add">
      <Name>Dfault</Name>
      <Group>Administrators</Group>
      <Password>
      <Value>password</Value>
      <PlainText>true</PlainText>
      </Password>
      </LocalAccount>
      </LocalAccounts>
      </UserAccounts>
      </component>
      <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <InputLocale>en-us</InputLocale>
      <SystemLocale>en-us</SystemLocale>
      <UILanguage>en-us</UILanguage>
      <UserLocale>en-us</UserLocale>
      </component>
      </settings>
      </unattend>
      • I created this install to do my first dell tablet with last April and it went great.
      • Hmm, I don't see anything significantly different than my unattend, maybe I should try again.
      • this is 8.1 enterprise,
        should not matter, the machine I uploaded to Kace was also UEFI formatted
  • Yes, I am using the OEM Dell Windows 8 Pro DVD. I am in the process of uploading the VL DVD as a test. Do you think the OEM DVD is the problem?
    • I have seen the OEM disks due strange things and not even work at all. they have some of their own special commands a lot of the times.
      • My Dell Win XP and 7 discs worked fine with scripted installs. I assumed 8 would be the same. I'll let you know how the VL disc works.
      • if not we will help u figure it out
      • are you booting to the kbox with an UEFI boot stick or pxe booting?
      • PXE boot
      • aha!!!!!!!!
        that is your problem
        the kbox does not support direct UEFI booting you need to create uefi boot stick and set your bios to uefi mode on the target machine
      • Nice catch, that is definitely the issue.
      • Can you supply a link that explains this? I'm totally new to UEFI and will admit I don't know what I'm doing. I've worked in the BIOS world for so long...
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
Please log in to comment
Answer this question or Comment on this question for clarity