/bundles/itninjaweb/img/Breadcrumb_cap_w.png
When installing software on Windows 7 often times you see a dialog at the end that says:

This program might not have installed correctly
- reinstall using recommended settings
- this program installed correctly

This link says how to shut it off on a per-machine basis
http://gnoted.com/disable-this-program-might-not-have-installed-correctly-windows-7/

Can you disable this via GPO's? We need to turn this off on 2,000 Windows 7 machines.
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
Ooops! Some outstanding software pilot staging there, eh? This should be in the build but, obviously, it's too late for that. Make sure it's in the next release.

Create a package which stops then disables the service. Alternatively, IIRC, you can set a program's compatibility in your packages.
Answered 09/02/2011 by: VBScab
Red Belt

Please log in to comment
0
I can do the service part no problem. how/where do you set the compatibility in your package?
Answered 09/02/2011 by: mhsl808
Fifth Degree Brown Belt

Please log in to comment
0
They are set in the registry.

Here is one I set for an exe and a service to run as W2K3SP1 on W2K8 x86 or x64.
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files\\Quark\\Quark_License_Administrator\\Server\\QLAServer.exe"="WINSRV03SP1"
"C:\\Program Files\\Quark\\Quark_License_Administrator\\Server\\QLAServerService.exe"="WINSRV03SP1"
"C:\\Program Files (x86)\\Quark\\Quark_License_Administrator\\Server\\QLAServer.exe"="WINSRV03SP1"
"C:\\Program Files (x86)\\Quark\\Quark_License_Administrator\\Server\\QLAServerService.exe"="WINSRV03SP1"

The default is to set it under HKCU, but you can change it to HKLM without issue.
Answered 09/02/2011 by: jmaclaurin
Third Degree Blue Belt

Please log in to comment
0
I'd be tempted to NOT disable the service but ensure that the flag is set for whichever executables require it.
Answered 09/02/2011 by: VBScab
Red Belt

Please log in to comment
0
I stopped and disabled the service and then added the reg key (under HKLM) and I still see this dialog pop up. I was a little unsure what to add in the reg so my guess is I added it wrong. I put this in:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"\\\\Server\\Share$\\App\\SourceFiles\\setup.exe"="AppName"

Is that wrong?
Answered 09/02/2011 by: mhsl808
Fifth Degree Brown Belt

Please log in to comment
0
Download the ACT
Answered 09/02/2011 by: VBScab
Red Belt

Please log in to comment
0
I already have the ACT, what part of it do I need? I need to create a shim?
Answered 09/06/2011 by: mhsl808
Fifth Degree Brown Belt

Please log in to comment