I'm a bit stuck finishing up my new Win 7 master image. I'm imaging using my k2000 System Image. After deploying a syspreped win 7 image onto a box the following post install task is ran.

cscript c:\windows\system32\nopower.vbs
regedit.exe /s c:\windows\system32\desktop.reg
{Task then deletes sysprep files}

I know this task runs because it deletes my unattend.xml file and others.
What it is not doing is running those first two line correctly.

The vbs script sets registry entries for physical NICs to disable power management. This is a must have.
the desktop.reg changes the background of the local admin account (current user) so that it is obvious when the local admin account is logged in. I can't have this set before hand because we use the admin account to setup the default profile during sysprep.

It appears some registry entries can't be changed until the computer has finished logging in all the way. I have a few other registry changes id like to make but havn't attempted yet.

help would be much appreciated.
Answer Summary:
The power settings can't be changed at the first log in after sysprerp. In fact you can't pull up the network interface properties GUI. I had to script my images to restart and login a second time.
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
2
Not that anyone cares but the power settings can't be changed at the first log in after sysprerp. In fact you can't pull up the network interface properties GUI. I had to script my images to restart and login a second time. How annoying is that?
Answered 01/24/2012 by: Tentacle Master
Fourth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity