I've noticed in the logs that sometimes the agent sometimes uses the FQDN for the K1000 server and sometimes it just uses the hostname. For example, sometimes it looks for helpdesk.domain.com and other times it just looks for helpdesk. This causes a problem for machines not connected to the domain and given a static IP. Granted, this is an unusual situation and easy to solve, but requires manually editing the workstation config before I can run any scripts or deploy an agent.

I found I could force the full hostname with amp.conf configuration, but auto-deployment would overwrite this and put in just the hostname.

Is there a configuration of the K1000 that would force the agent to deploy with the fqdn instead of just the hostname for all communication?

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2

You can make the change in two places.

 

1. the network settings to reflect the FQDN instead of the short name

2. when doing the advanced provisioning, change the short name manually to the FQDN before saving or running it.

Answered 10/15/2012 by: nshah
Red Belt

  • I tried #2 and that didn't seem to work. I changed the amp.conf to reflect FQDN as well as in advanced provisioning for that machine and it revert to the short name.

    for #1, do I need to remove the domain name so it doesn't append the domain on in some places and start failing at that point?
  • For DNS and Webserver settings under Network, kace recommends using FQDN for both that way there isn't an issue and a short name alias can be put in DNS if needed.
    • Thanks Nshah, will I brake anything by changing that if it has already been running without FQDN in both those places?
Please log in to comment

Answers

1

That's where I made the change. ^^^

It was previously blank.

Answered 10/18/2012 by: flickerfly
Purple Belt

Please log in to comment
1

if you change it under the nic  the only problems you may run into is if you have more then one system with the same name you are calling to (this should never happen).  Just do not set the "use  this connections DNS....." check box

Answered 10/16/2012 by: SMal.tmcc
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity