I would like to have 100% responsive to WoL. However, I am having some issues with the various hardware and software configuration options, and am looking for some advice.

My test system is an Optiplex 740 with a Broadcom Netxtreme 57xx  is network interface

As far as I can tell, there are 3 areas where WoL behavior is configured. These are:

Windows Network Interface Power Management - A tab in the network interface's properties. 

I would rather not have Windows turn off the device to save power, but my testing has shown that if Windows Power Management isn't enabled for the interface, the system doesn't respond to wake requests when it is sleep mode. Does anybody have any explanation for this?

Advanced Driver Settings:
 

The alternative configuration settings for Wake Up Capabilities are Magic Packet, Wake Up Frame, None, or Both. Both is the default. I haven't ever dealt with this, but it varies depending on the network card, and driver.

BIOS Settings:


 Remote Wake Up must be on, and Low Power Mode must be off.

So with these settings configured as pictured above, I am able to wake a computer from shutdown and from sleep (hibernation is disabled). My problem is that, after  ~3 hours (or less), the system stops reacting to wake requests.

What could be causing it to stop responding to wake requests after some time period of having been shutdown?

Has anybody else wrestled with WoL and come through the other side? 

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

3

I wrestled with it and had internal resistance to change but had a similar issue.

In our instance, the MAC address tables on switches and routers have a setting to clear the tables after "X" hours. Once you turn off the PC and it hits that magic number, the MAC is flushed and the network hardware doesn't know where to send the WOL packet any longer. There are apparently issues to changing this setting, and my team wasn't willing to alter the value.

It's pretty frustrating, so I'd love to hear other suggestions.

Answered 03/15/2013 by: tshupp
Second Degree Black Belt

  • We got this working by enabling subnet directed broadcasting on our network gear. I believe we had to specify the host IP where the WoL packets would be coming from and a port which Altiris was using 402. With subnet directed broadcasting enabled anything send to the subnet on the broadcast address which is x.x.x.255 will be broadcast to every endpoint on the subnet.
  • Wow, this actually makes a great deal of sense. I will have to check with my networking team on this.
  • Were you able to set up a test environment to verify that this was the issue?
    • Brought in an old consumer router and tested; WOL settings allowed the wake after the typical 4 hour window I was seeing when the units were on our network infrastructure. That's what led me to talking to our network group. YMMV.
Please log in to comment

Answers

1

You seem to have covered most of the usual "gotchas" we ran into when setting up WoL for our Optiplex 780s, but here are couple of extra things you can check:

  • In the BIOS, look the bios for Hibernation or Automatic Sleep and make sure those settings are off. 
  • Go to one of the "problem" machines. While it is shut down, look at the NIC from the outside where you plug in the cable. There should be amber or green lights blinking slowly. If not, either the card isn't getting any power or WoL is disabled/unsupported.
  • Check firewall logs to make sure your magic packets aren't being blocked - this is UDP port 9.
  • Download wolsniffer.exe from Depicus and netscan.exe from SoftPerfect. Use netscan to send a magic packet while you have wolsniffer running on the target. This will at least tell you if the target machine is seeing it. 
  • We turn OFF those power management settings you have in your screenshot - we found that WoL would apparently, randomly stop working if we had anything in that screen enabled. 
  • Some resources recommend installing Simple TCPIP services from Control Panel > Turn Windows Features On/Off and setting it to automatic. We have not had to do this.
Answered 03/15/2013 by: HealthITAdmin
White Belt

Please log in to comment
0

Sorry, this is not an answer but someone else struggling with the problem looking for help.

We have set up one VLAN on our network that has OptiPlex 780's behind a new firewall and they all fail to wake up.  We added a 9010 to that VLAN and it wakes up every time without fail.  That is when we noticed in the switch MAC table, the MAC address of the 9010 is persistent (which allows the unicast WoL packet to locate the target device) while the MAC addresses of the 780's age out and are dropped from the table.  Once those MAC addresses age out, the unicast packets can’t find their destination.

The new firewall we are implementing is a Palo Alto which absolutely does not support the directed broadcast mentioned above, so unicast is the only option.  What we need now is to figure out the difference between the 780's and the 9010 and hopefully implement a tweak or fix for the 780's so their MAC addresses will remain persistent in our switch MAC tables.

Anyone got any ideas?   Thanks so much!!!

 

Kris

Answered 05/26/2014 by: kpratt@cfcc.edu
White Belt

Please log in to comment
0

We've been looking to implement WOL for after hours activities, but we aren't quite there yet. Thank you for this post of things to watch out for!

Answered 03/18/2013 by: GeekSoldier
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share