Wake on LAN doesn't work very well on the K1000. I can take a brand new PC out of the box and power it on long enough to retrieve the MAC address, then shut it back down. If I manually enter the MAC and any valid IP address on the network into the K1000 Wake-on-Lan Manual Entry section, the PC won't power on. My understanding is that the IP address is only needed so the K1000 knows what subnet to send the broadcast packet on. I have tried third party freeware WOL tools such as SolarWinds, and they wake up the machine just fine.

What I have found is that if a PC on the network is getting its IP address using DHCP, WOL from the K1000 will turn on the PC if it uses the last known IP for the machine, AND no other PC has been assigned the IP you are trying to use.

Anyone else having issues with WOL?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
WOL works at the ethernet layer using something called the "magic packet", a packet crafted for each individual machine using that machine's IP address. Normally, it's sent at the ethernet layer directly to that MAC address. It's not on the TCP/IP layer, and is thus not normally routable beyond subnet boundaries.. What the K1000 does, in an attempt to get the magic packet around, is to encapsulate it into an IP broadcast packet aimed at each IP subnet the machine may be on, based on its last IP address. It's sent as an IP-layer broadcast packet directed at that IP subnet, which means that your routers have to have directed broadcast turned on for the packet to cross subnet boundaries. Consult your router documentation for ways to do this that minimize the negative security implications.

WOL is also normally turned off in the BIOS. You may want to check to see that it's turned on.
Answered 04/04/2011 by: jkatkace
Purple Belt

Please log in to comment
0
We are having similar issues with WOL. When our machines have been off for a x-amount of hours, wake on LAN will not work via the kbox. This does work with the SolarWinds WOL utility. However, if I turn on a computer, turn it off, I can then use the kbox to push out WOL commands with no problem.

Of course, I really don't need to utilize WOL until the middle of the night when the initial command will NOT work.

I know it isn't a DHCP lease issue on our end. Machines retain their IPs. Were you able to find any resolution with this?
Answered 04/20/2011 by: jpuckett
Senior Yellow Belt

  • This is exactly the issue we are having. Not sure I follow where the fix is found though. Can anyone help? If a machine has been off for x-amount of hours, can't use the kbox to wake it up. If the machine is then booted up and shut down, it wakes up fine. Thanks for any help!
    • I'm dealing with a similar issue and it is most likely related to the flushing of ARP tables in a switch. since there is no MAC to port/IP record there is nowhere for the magic packet to go. We use cisco switches over several subnets
Please log in to comment
0
I have WOL set up through KACE on 3 computers and everything is working great with it. There are a couple settings in BIOS that need to be changed for it to work correctly. Also if you have a schedule make sure it is enabled.

What model computers are you trying to set up WOL for. I can help you with the BIOS settings to make sure you have them all set up correctly. I was missing one setting and it would work intermittently. I then changed this other setting and now everything works great. I have a schedule to shutdown M-F at 7PM and WOL M-F at 6:50AM. I've checked my logs and everything is working the way it should.
Answered 04/20/2011 by: blentz31
Purple Belt

Please log in to comment
0
Our computers are mostly HP.

What setting did you miss that was causing it to be intermittent?

Most of ours are working but some not all the time.
Answered 01/25/2012 by: jfrasier
Seventh Degree Black Belt

Please log in to comment
0
WOL is not a reliable way of waking a machine unless you are on the same "network" (subnet, not routered via a router etc) since it's a broadcast, and I'm sure if you ask a network guy he might not be too found of enabeling broadcasts to bypass the routers since that will just create more network noise.

Another way of doing it and a lot more reliable is to use vPro if you machines support that :)
Answered 01/27/2012 by: rmeyer
Second Degree Blue Belt

Please log in to comment
0
Have you networking folks take a look at the MAC address tables on your switches / routers. Ours were set to clear after 4 hours. We've extended ours to 48 or 60 to solve this problem.
Answered 01/27/2012 by: paulrkrueger
Senior Yellow Belt

Please log in to comment
0
We had a similar problem with WOL on dell pcs but after I verified that Low Power mode was off in the bios and wake on lan was in enabled in the bios the pcs now wol fine. For the pcs that issues I used DCCU to push out bios settings through KACE.
Answered 01/27/2012 by: quickwhips
Orange Belt

Please log in to comment
0
What you might be seeing is the infamous sleep problem with WOL. The WOL spec was designed to turn on machines that are powered off; it was never intended to wake a machine that was only in a sleep mode, since sleep modes weren't really used back then. In other words, WOL is "wake from off", not "wake from sleep".

In some models of computers, you can adjust the options in Device Manager to make "wake from sleep" work on some NICs. Dell published a paper or utility on this a couple of months ago for their OptiPlex line, but I can't find the reference now.

Once I understood that the machines had to be off, not sleeping, for WOL to work, the K1000 WOL has been 100% successful on the Dell OptiPlex and Lenovo ThinkPad models we have. BTW, we enable WOL on the Dells using the Dell Client Configuration Tool Kit (CCTK) (the successor to the DCCU) from a Kscript.

For better control in the future, we're looking into the Intel AMT software used with Intel vPro CPUs. There was a session on this at the 2011 KACE Konference.

Has anyone found any better solutions to the sleeping problem? Sande
Answered 01/27/2012 by: snissen
Fourth Degree Green Belt

  • I've been running into an issue where our K1000 will successfully wake one or two computers at a time no problem, but when I try to wake an entire computer lab, maybe ~25% of the computers actually power on, and the computers that successfully responded in previous tests didn't wake up. Most of the hardware is identical (Optiplex 380s) and I've already set their BIOS to enable WOL (and to disable Low Power Mode), so I don't think it's a client configuration issue. Is this consistent with some form of network infrastructure fault that needs to be investigated first, or should I be talking to KACE support on why WOL isn't working as expected?
Please log in to comment
Answer this question or Comment on this question for clarity