Hey Guys,

have any of you had the 'pleasure' of packaging this application? If so please tell me how you set the user properties (things like update schedule, startup behaviour, locking code and settings...)
There's supposed to be a "Vodafone Mobile Broadband Administrative Install Guide" (it's mentioned in one of their documents) but as far as I can tell there is no such document on their site. The only ones I can find are for the (older) Mobile Connect.

It seems like just copying over the MobileBroadbandProfile.XML file into the user's appdata (as used to be done for Mobile Connect) folder isn't enough. I've also changed the Startup mode away from "first time run" to "full window startup", done a first start capture and found some HKCU regkeys, but nothing. It seems like the thing stubbornly keeps resetting for users.

If any of you have a definitive guide to propagating settings for this thing to all users, any help would be GREATLY appreciated

PJ
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1
I got it to work in the end. I've submitted my findings to the package KB for future reference.
Answered 11/08/2010 by: pjgeutjens
Red Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
To break the monologues and silence for a change: Thanks in advance, for whenever I'm going to need it. Your work is silently appreciated by many more :)
Answered 11/08/2010 by: Rheuvel
Brown Belt

Please log in to comment
0
What did you do to fix the issue? I am having same issue. I could not find anything on the Package KB. Can you please give me some more information how did you resolve the issue?
Answered 11/09/2010 by: jsolanki
Senior Yellow Belt

Please log in to comment
0
The link to Pieter's Package Kb article is at the top of this thread's page.
Answered 11/10/2010 by: VBScab
Red Belt

Please log in to comment
0
Ian,

I'm just seeing a blank KB entry - nothing visible for me in the link you provided.

Is AD being weird?

Thanks,

Dunnpy
Answered 11/10/2010 by: dunnpy
Red Belt

Please log in to comment
0
New entries aren't being approved. I've submitted something on monday and it still says [Pending]. Someone wake up Bob [8|]
Answered 11/10/2010 by: Rheuvel
Brown Belt

Please log in to comment
0
Sorry guys, I'm at the Dell KACE User Konference this week and haven't been keeping up as well as usual (typically I do this at least every other day). I'm on it!
Answered 11/10/2010 by: bkelly
Red Belt

Please log in to comment
0
It's like some sort of alarm goes off when someone says "Bob".

Anyways, thank you Bob!
Answered 11/10/2010 by: Rheuvel
Brown Belt

Please log in to comment
0
Hi guys,

PJ thanks for your initial findings, it did help when I started trying to deploy VMB 10.

Unfortunately, I still cannot seem to prevent it prompting me on first time use for whether I want to use "Contract" or "Prepaid".
I've gone through a first install scenario and copied the mobilebroadbandprofile.xml file containing the settings to use as a template. Even though these are present and being used (as far as I can see), I'm still getting prompted.

Selecting either of the options stops the prompt coming up next time the user starts the app, but I don't want it coming up on the first run for any of our users.

I've specified "Contract" in the ACCOUNT_PROP property, but this wasn't getting fed through to the CustomerAccount reg key in HKLM which I thought might be the problem, but manually entering a value in this key didn't seem to help.
Using a transform, I altered the CustomerAccount reg string so that its data is coming from [ACCOUNT_PROP] rather than [ACCOUNT_PROP_REG] as this didn't seem right (there is no property called ACCOUNT_PROP_REG) and might explain the empty value. It worked (the reg string is populated in HKLM now) but of course didn't help prevent the prompt for Contract/Prepaid.
Entering a value for the UserAccount string in HKCU doesn't help either.

I've tried setting VMCSTARTMODE to 1, tried setting it to 3. Makes no difference.
I thought I'd solved it by poking a value into the "SetupTime" string in Current_User but it must be something else as well causing the MobileConnect.exe to prompt for the contract type.
<AskAccountType> is set to false in Opco-23415.xml

Deleting the Vodafone folder in the user's Application Data folder doesn't cause the prompt to reoccur so in my mind, what's causing it to prompt isn't held in any of the .xml files in Application Data.

This is proving a lot harder than configuring and deploying Vodafone Mobile Connect 9 and there's still no sign of the Admin Install guide for this version of the software...
Everything in the documentation seems to point towards the values I've already set being the key, but it's not helping.

Sorry for rambling on, but it's driving me mad.
Has anyone else managed to get this to work?

Thanks,
Al.
Answered 06/07/2011 by: AWillis
Senior Yellow Belt

Please log in to comment
0
Let's see...

Did you add all the HKCU keys I mentioned in the package KB?
most notably this one:

"HKEY_CURRENT_USER\Software\Vodafone\UserAccount", "<contract type>"

PJ
Answered 06/07/2011 by: pjgeutjens
Red Belt

Please log in to comment
0
Thanks for the reply,
Yes, I've added the following HKCU keys in:
[HKEY_CURRENT_USER\Software\Vodafone\VMB]
"SetupTime"="20110606151825"
"LockingCode"="<lockingcodevalue>"
"VF_PLMN"="23415"
"VF_COUNTRY"="United Kingdom"
"OemDetermined"="Automatic"
"ConfAppsModeStatus"="ManualForFirstRun"
"ReportingSent"="00000000000000"
"ReportingCurrentToSendNumber"="6"
"VF_PHONE_PREFIX"="+44"
"VF_DisplayLocalNumber"="true"
"ReportingLastSentNumber"="0"
"UserAccount"="Contract"

One thing I've noticed that is different is that I'm putting these values into HKEY_CURRENT_USER\Software\Vodafone\VMB, rather than into the root of Vodafone.
AcceptedEULAs is also not set here, but the value is set in HKLM and I'm not prompted to accept a EULA when starting Vodafone.

Thanks for your help,
Al.
Answered 06/08/2011 by: AWillis
Senior Yellow Belt

Please log in to comment
0
As a test, I tried running the install using the setup_vmb.exe and selecting Vodafone UK (23415) as the OPCO, I'm not prompted for Contract or Prepaid while going through the install.
This looks like it's down to the <AskAccountType>false</AskAccountType> setting in Opco-23415.xml.

The documentation seems to indicate that this should be the case, "depending on the selected operator, not all screens may be shown", and that "hiding this window means that the Account Type can also be selected later during first-run".

So...in the admin install I've been using, I modified the Opco-23415.xml file so that AskAccountType is true, and also changed the property OPCOCONFIG_ASKACCOUNTTYPE from false to true.
I'm now prompted for the Account Type and can select Contract at this point and complete the install.
Despite this though, I'm still prompted to select how I pay for my service when I start Vodafone Mobile Broadband (I'm still logged on as the same user I installed the application with).
Doesn't make much sense to me - wondering if something I'm setting in the transform is overriding what I'm selecting at point of install.
Answered 06/08/2011 by: AWillis
Senior Yellow Belt

Please log in to comment
3
Finally got this sorted out after speaking to Vodafone Support:

Had to make a couple of changes:

  • Modify Opco-23415.xml to include the following line in the <Setup> section:

<AskMarketSegment>false</AskMarketSegment>

e.g.
<Setup>
[blockquote]
<AskReports>false</AskReports>
<AskMarketSegment>false</AskMarketSegment>[/blockquote]
</Setup>

Prevents the prompt for account type being changed on first run.

    Modify the 23415.xml file to include SwitchMarketSegment="false" in the APNs section

e.g.
[font="times new roman"]<APNs SwitchMarketSegment="false">
[font="times new roman"] <APN Account="Contract" Apn="internet" Name="Contract" Pass="web" User="web">
[font="times new roman"] <Security>PAP</Security>
[font="times new roman"] </APN>
[font="times new roman"] </APNs>


Prevents the prompt for account type being changed at run time.


Hope this helps anyone else having a similar issue.
Answered 06/24/2011 by: AWillis
Senior Yellow Belt

Please log in to comment
0
Great work! I have 'Rated' your post.

Would you mind creating a new 'Note' entry for the package in the 'Package KB'?
Answered 06/24/2011 by: VBScab
Red Belt

Please log in to comment
2
ORIGINAL: VBScab

Great work! I have 'Rated' your post.

Would you mind creating a new 'Note' entry for the package in the 'Package KB'?


Thanks!
Vodafone support were very helpful. I've suggested they include something in their documentation about the two properties that I had to alter and asked about the missing Admin/Enterprise guide for VMB 10 [;)]
I've submitted a new 'Note'.
Answered 06/28/2011 by: AWillis
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity