Does anyone know of a way to give the user a choice to allow or deny a VNC remote connection?, we are trialling KBOX as an alternative to our current remote managment software and this is important to us to allow user privacy. i have installed Ultra VNC on a number of machines but have yet to find a setting where the end user is prompted to allow or deny the remote control of their machine.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
RealVNC Says there's a setting:
Prompt local user to accept connections
QueryConnect=true|false

By default, VNC Server allows Viewers to connect as long as the correct username and password are supplied. QueryConnect allows an extra level of protection to be applied, requiring a local user to explicitly accept incoming connections.
When QueryConnect is enabled, incoming connections are first authenticated in the normal way. If the user authenticates successfully then a dialog is presented on the server's desktop, displaying the IP address and username of the incoming connection, and requiring a local user to accept the connection.
If the user does not accept the connection within a specified timeout then it is rejected. If an incoming connection requiring acceptance by the local user is received while an earlier connection is being queried then the second connection is automatically rejected, for security reasons.
Connections from specific hosts or subnets can be configured to be queried via the Hosts configuration setting.

I'd think that you could set this using scripting, managed install, or registry edits.

Microsoft Remote Assistance does this by default also. You can launch it with: hcp://CN=Microsoft%20Corporation,L=Redmond,S=Washington,C=US/Remote%20Assistance/Escalation/Unsolicited/unsolicitedrcui.htm
Answered 09/21/2010 by: cblake
Red Belt

Please log in to comment
0
ah, so this would require us to use RealVNC as our client?, ill take a look at that, i should have specified that we were using UltraVNC as per the instructions on the KBOX walkthrough.
Answered 09/21/2010 by: trentderby
Blue Belt

Please log in to comment
0
the query option is available with UltraVNC that is bundled with the K1000

most of the UltraVNC settings are stored in the ultravnc.ini file.

The general rule of thumb is install UltraVNC, make your changes to update the ini file and then copy over that ini file to add/replace as the dependency in the K1000 UltraVNC deployment script.
Answered 09/21/2010 by: tstaub
Second Degree Blue Belt

Please log in to comment
0
thanks guys for anyone else trying to do this i copied my ini (relevant parts in bold)


[Permissions]
[admin]
UseRegistry=0
MSLogonRequired=0
NewMSLogon=0
DebugMode=0
Avilog=0
path=C:\Program Files\UltraVNC
DebugLevel=8
DisableTrayIcon=1
LoopbackOnly=0
UseDSMPlugin=0
AllowLoopback=0
AuthRequired=1
ConnectPriority=0
DSMPlugin=
AuthHosts=
AllowShutdown=0
AllowProperties=0
AllowEditClients=0
FileTransferEnabled=1
FTUserImpersonation=1
BlankMonitorEnabled=1
DefaultScale=1
CaptureAlphaBlending=0
BlackAlphaBlending=0
primary=1
secundary=0
SocketConnect=1
HTTPConnect=1
XDMCPConnect=0
AutoPortSelect=1
PortNumber=0
HTTPPortNumber=0
IdleTimeout=10
RemoveWallpaper=1
RemoveAero=1
QuerySetting=4
QueryTimeout=10
QueryAccept=0
QueryIfNoLogon=1

InputsEnabled=1
LockSetting=0
LocalInputsDisabled=0
EnableJapInput=0
kickrdp=0
service_commandline=
FileTransferTimeout=30
[admin_auth]
group1=
group2=
group3=
locdom1=0
locdom2=0
locdom3=0
[ultravnc]
passwd=
[poll]
TurboMode=0
PollUnderCursor=0
PollForeground=0
PollFullScreen=0
OnlyPollConsole=0
OnlyPollOnEvent=0
EnableDriver=0
EnableHook=0
EnableVirtual=0
SingleWindow=0
SingleWindowName=
Answered 09/27/2010 by: trentderby
Blue Belt

Please log in to comment
0

Hi, Currently we are facing issue in VNC server setup on x64 bit computers in our environment. When a connection is initiated, the username column is grayed out and gives an option only for password (dispalys anonymous is requesting for connection on the computer). Can someone suggest me how to make this setting change in the environment.

Answered 06/13/2012 by: Karthika31
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity