I am working on the vendor msi and i need to disable the AutoUpdate check option. When i launch the application this dialog box pops up asking me" if i need to check for the product updates" . Can somebody tell me how can i turn the AutoUpdate off?

Thanks
Sam
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
There are 2 ways to go about this. 1 is to open the msi in Orca or Wise MSI editor and find out what that property is called (look in the properties table). You can then set it in the MSI via command line options like this: msiexec /i A:\Example.msi PROPERTY=VALUE (where PROPERTY is the name of the property and VALUE is whatever the checked value is.) The second option along the same lines is to create a transform package and use that when running your original MSI. I know Orca can do this as well but haven't used it for this purpose. Wise is a little better suited for creating transforms. They are pretty easy to make.
Answered 10/15/2007 by: yarborg
Blue Belt

Please log in to comment
0
Open the MSI in Orca and look for a table under Property called ISCHECKFORPRODUCTUPDATES. Try changing the Value from 1 to 0. This may or may not work but it's worth a shot.
Answered 10/15/2007 by: dpolishsensation
Blue Belt

Please log in to comment
0
Sam,

It would help if you could say which application you're referring too.
Have you looked in the Package KB for any reference of the application?
Answered 10/15/2007 by: AngelD
Red Belt

Please log in to comment
0
I am working on Romeo and Dye's section 16 and its not in the package KB. I've also tried ISCHECKFORPRODUCTUPDATES=0 in the property table its still asking me the same option after i launch the app.
Answered 10/15/2007 by: chichora2003
Orange Belt

Please log in to comment
0
I am working on Romeo and Dye's section 16 and its not in the package KB. I've also tried ISCHECKFORPRODUCTUPDATES=0 in the property table its still asking me the same option after i launch the app.
That's because ISCHECKFORPRODUCTUPDATES is used by InstallShield-built (and dependent) MSIs. If your product doesn't use InstallShield, this is irrelevant.

You need to walk through the Property table looking for a property with a likely-looking name. If there's nothing there, turn your attention to the Custom Action table. Many vendors set options by calling functions in DLLs via custom actions.

If you are unable to locate either, it might be worth monitoring the app with ProcMon (or your favourite file/registry monitor) and/or force it to auto-update. You'll then see immediately what file/registry activity is involved.
Answered 10/16/2007 by: VBScab
Red Belt

Please log in to comment
0
The "AutoUpdate check option" may be a application configuration and not an MSI related thing.

My best guess would be that it's stored in the registry or a file.
Using Ian's favourite tool (ProcMon) ;) should work this out.
Answered 10/16/2007 by: AngelD
Red Belt

Please log in to comment
0
What I do for these types of issues is this:

1./ Install app on your base system.

2./ run the application with 'procmon' running so it captures the registry changes. You can download this free utility frmo Sysinternals

3./ When youa re prompted click 'No' and see if it captures anything.

More cases then not there is a registry key entry under the HKLM/Software/<AppNAME> that refers to this feature and can be turned off. If you find such a key you can turn it off and export that key and add it to your MSI's registry ADD or create a custom action to add it. If you don't want to repackage to do this you can create a batch file that calls the MSI and then applies the registry change using REG or REGEDIT.

Good luck.
Answered 10/16/2007 by: Coriolus
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity