I am trying to create an admin xml file:
vs_professional.exe /createadminfile \\filelocation\admin.xml

And getting an error when trying to insall with "vs_professional.exe /adminfile \\filelocation\admin.xml"

There are some validation errors in the admin deployment metadata xml provided.

What am i missing??
5 Comments   [ + ] Show Comments

Comments

  • please share the XML and the error details.
  • I am also facing same error could anyone help me on this for me xml file is not created
  • If you are installing on windows 7 you need to select the windows 8/10 sdk otherwise you might ens up with the error you are receiving.

    The log which should be present in %TEMP% Will till you more.
    • where can I select that windows 8/10 sdk? Can you please tell me the command line what should be used to create admin deployment file? I am using /AdminFile. I am getting this error "There are some validation errors in the admin deployment metadata xml provided"
  • shouldn`t your quotes look like this instead ? : vs_professional.exe /adminfile "AdminDeployment.xml" /quiet /norestart
    • i am getting an error stating that admin file has issue (when removed quiet )..i created a vanilla xml file and still getting same error. what am i doing wrong
      • what i do is run a batch file to copy source files locally and then the batch file executes the command line of VS_professional.exe /adminfile "c:\copied_xml_location\file.xml" /quiet /norestart /ProductKey "enter prod key here"
      • check here for more info https://msdn.microsoft.com/en-us/library/ee225237.aspx
  • as the deployment was failing i tried running the command line locally from Admin Cmd...and i am getting a error saying that xml file is having issue.. is there any step by instuction to create that xml file (tried with /createAdminfile and used as is and still got error..
Please log in to comment

Answers

0
Oh my god this annoyed the pants of me.

The solution is to put the path of the admin file in quotes after the /adminfile switch.

So my installer now looks like .\vs_enterprise.exe /AdminFile "c:\jobs\vs\AdminDeployment.xml"

Also, make sure to edit AdminDeployment.xml and change NoWeb="default" to NoWeb="yes"

This isn't very well documented - so I hope people find this useful! This is at least what worked for me - if you have a different problem that you have solved be sure to post it here to help others! :)
Answered 10/18/2016 by: oxforditninja
White Belt

  • Just to clarify my full options for deployment are .\vs_enterprise.exe /adminfile "c:\Jobs\vs\AdminDeployment.xml" /quiet /norestart /ProductKey ABCDEFGHIJKLMNOPQRSTUVWXY
Please log in to comment
Answer this question or Comment on this question for clarity