[:(]I have installed the Kace browser on a Windows 7 Home premium.
When I try to start the browser I get the following dialog box:
-------------------------------------------------------
Alert
Could not initialize application's security component.The most likely cause is problems with files in yourapplications's profile directory. ........
--------------------------------------------------------
Any ideas why it is not working on my laptop?
Many thanks


0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Perhaps your security settings are modified somehow from a standard system as this has never been encountered in testing or reported by others. The application is actually running from %ProgramFiles%\Dell KACE\Secure Browser (Firefox)... if that helps.
Answered 09/13/2010 by: bkelly
Red Belt

Please log in to comment
0
Hello,
I got the same alert message on my system (Windows 7 64Bit Ultimate). Its a fresh installed Kace browser v5.1.1657 with standard settings.
My UAC setting is on the highest level. But a change to the normal setting make no changes to the program start. The deactivated Avira AntiVir scanner brings also no effect.
Hope you can fix this.
Thanks!
Flc
Answered 09/26/2010 by: Falcon
Yellow Belt

Please log in to comment
0
We are having trouble reproducing this situation in order to address it. Can you think of anything about your environment that may contribute to an explanation? Would you mind sharing a list of what other applications you have installed?
Answered 09/29/2010 by: bkelly
Red Belt

Please log in to comment
0
This error is an actual Mozilla Firefox error prompt.

There is a knowledge base article on Mozilla's support site:
http://support.mozilla.com/en-US/kb/could+not+initialize+the+browser+security+component

We were able to duplicate this by setting the cert8.db file to read only. It's possible that this file has been set to read only on your system, which then results in the error you are seeing.

Take a look at this knowledge base article and see if it helps. If not, please get back with us.

-Trey
Answered 09/29/2010 by: TThomas
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: bkelly

We are having trouble reproducing this situation in order to address it. Can you think of anything about your environment that may contribute to an explanation? Would you mind sharing a list of what other applications you have installed?


Here is a screen shot of my programs. Hope it helps.

@TThomas: I was not able to find the cert8.db on my system.
Answered 09/30/2010 by: Falcon
Yellow Belt

Please log in to comment
0
Falcon,

The cert8.db is going to be in the AppData folder, which is normally hidden by default.

For example, below is the location of mine on Windows 7

C:\Users\Me\AppData\Roaming\Mozilla\Firefox\Profiles\cj4hbduy.default

-Trey
Answered 09/30/2010 by: TThomas
Senior Yellow Belt

Please log in to comment
0
Thanks for this hint. I've found it now (the TotalCommander search function don't find hidden files!).
But the Secure Browser use this path, right?
C:\Program Files (x86)\Dell KACE\Secure Browser (Firefox)\Secure Browser (Firefox with plugins)\Firefox\Files\C\Users\[username]\AppData\Roaming\Mozilla\Firefox\Profiles\[...].default\cert8.db

My check: The file is at full access for users. This can't be the problem.
Answered 09/30/2010 by: Falcon
Yellow Belt

Please log in to comment
0
Falcon,

Yes, the path below is what Secure Browser creates and uses for the Konatined version of Firefox.
C:\Program Files (x86)\Dell KACE\Secure Browser (Firefox)\Secure Browser (Firefox with plugins)\Firefox\Files\C\Users\[username]\AppData\Roaming\Mozilla\Firefox\Profiles\[...].default\cert8.db

But, during the install, it looks at the C:\Users\[username]\\AppData\Roaming\Mozilla\Firefox\Profiles\[...].default\cert8.db and if there is a profile there, copies over certain files.

cert8.db is just one of these files.

It's possible that another file from the un-Kontained Firefox is being copied over, and then creating this issue. Does your 3.6.10 start up fine without any issues?

I did some more testing, and I think I might have found a work around for you until we figure out exactly what is happening.

In your Kontained Firefox, delete your profile in
C:\Program Files (x86)\Dell KACE\Secure Browser (Firefox)\Secure Browser (Firefox with plugins)\Firefox\Files\C\Users\[username]\AppData\Roaming\Mozilla\Firefox\Profiles\

Then, from a command prompt, navigate to
C:\Program Files (x86)\Dell KACE\Secure Browser (Firefox)\Secure Browser (Firefox with plugins)\Firefox\Files\C\Program Files\Mozilla Firefox
(I am running Windows 7 64bit, if you are not, you will just have C:\Program Files)

Once in this directory, type firefox.exe -profilemanager

This will start the Firefox Profile Manager within the Kontained version, and allow you to create a new profile that takes nothing from your previous install. After you create this, try launching Secure Browser.

Please let me know if you have any questions, and the results of this.

-Trey
Answered 09/30/2010 by: TThomas
Senior Yellow Belt

Please log in to comment
0
OK, it run's now. I've deleted the profile and created a new. But the "firefox.exe -profilemanager" works only when no firefox is running on the system.

Thanks for the help!
Answered 10/01/2010 by: Falcon
Yellow Belt

Please log in to comment
0
Falcon,

Yes, sorry about missing that step.

Glad to hear it is working. We are looking into this profile issue, and will look to have this fixed in the next release.

-Trey
Answered 10/01/2010 by: TThomas
Senior Yellow Belt

Please log in to comment
0
[:D]Hello Thomas,
perfect.
It`s working.
Many thanks for your help!
Gerd
Answered 10/16/2010 by: dagedaru
Yellow Belt

Please log in to comment
0
Thanks, we got lots of positive feedback and so have released this fix (along with updates to Firefox, Adobe Reader and Flash) in 5.1.1660 which can be obatined here: http://www.kace.com/products/freetools/secure-browser/
Answered 10/21/2010 by: bkelly
Red Belt

Please log in to comment
0
I downloaded and installed, with no problem, yesterday--12/16/10. So, I apparently have the fix mentioned. However, the path given is C:\Program Files (x86)\Dell KACE\Secure Browser (Firefox)\Secure Browser (Firefox with plugins)\Firefox\Files\C\Program Files\Mozilla Firefox. And, the secure browser will not start. I have tried with no startup items except those related to the secure browser enabled and with no startup items enabled. But, zee secure browser, she no start. Any thoughts? All help appreciated.
Answered 12/17/2010 by: Znod
Yellow Belt

Please log in to comment
0
The steps listed above in post #8 have not been implemented into the build currently available.

The path above is for installing this on a 64-bit OS.

What OS are you installing this on, and do you currently have Firefox installed? If so, what version?
Answered 12/17/2010 by: TThomas
Senior Yellow Belt

Please log in to comment
0
Thank you for your interest TThomas. I am running 64-bit Win7 Ultimate. The most up-to-date version of Firefox is installed. I am RAID 0, 3.2 MHz, and 8 GB dual booted with another 64-bit Win7 Ultimate drive that I use as a server. I would greatly appreciate any help you can give.
Answered 12/17/2010 by: Znod
Yellow Belt

Please log in to comment
0
Znod,

The mosty likely cause of your Secure Browser not starting up is the profile. It copies your current Firefox profile and uses it in the Secure Browser Firefox.

It is very difficult to be 100% compatible with all Firefox Add-Ons, so certain Add-Ons do not work in a kontained instance of Firefox.

Have you tried performing the steps in Post 9, deleting the Secure Browser Firefox profile, and creating a new one within the kontained instance? The path should be correct since you are using Windows 64-bit.

In the next release of Secure Browser, which should be in late Jan/early Feb, this specific profile issue has been addressed, and will no longer copy over the one from Firefox. It will create a new one every time.

-Trey
Answered 12/20/2010 by: TThomas
Senior Yellow Belt

Please log in to comment
0
My secure browser installation failed to start for the same reason mentioned in the first post. After deleting my profile and creating a new profile with the profilemanager it still did not work properly.
The problem was that
starting firefox.exe -profilemanager
from C:\Program Files (x86)\Dell KACE\Secure Browser (Firefox)\Secure Browser (Firefox with plugins)\Firefox\Files\C\Program Files\Mozilla Firefox
did not start the secure browser instance but my regular firefox profilemanager.
I had to type .\firefox.exe -profilemanager instead (notice the leading .\ ).
After that the secure browser worked correctly.

By the way don't get confused by the path to the profile directory that the profilemanager shows. It is the path in the virtual environment and not the path on your "real" system. So you can leave that path as it is.

Mark
Answered 12/22/2010 by: markkarm
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity