Hi all,

As the title mentions I'm having trouble pushing a custom build msi package through KACE. The msi package installs perfectly fine when installing it locally, but when pushing it through KACE, I get the following popup and nothing gets installed:

kvk0RP.png

This popup appears even when using msi commands such as /qn. KACE reports that the software has not been installed and shows a failed attempt.  We are currently using K1000. I'm pretty new at this, but I used MS Visual Studio 2013 to build the package. I didn't set any custom property values, but set a default installation directory. What exactly am I doing wrong? Is this an issue with KACE or how I built the msi installer? I'll be glad to provide more information if needed. I appreciate the help!
Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answer Chosen by the Author

0
Sorry for the late response! Here are the command lines I've tried to use:

msiexec /i Magtek Driver Install.msi
msiexec /i Magtek Driver Install.msi /qn /norestart

I tried using the Default Installation option with the same result.

I also tried the command line (c:\windows\system32\msiexec.exe /i Magtek Driver Install.msi /qn) from jknox with the same result.
Answered 05/19/2015 by: PancakeScene
White Belt

  • You have spaces in your filename so you need to surround it with quotes.
    • That was exactly the issue, i feel so stupid! Thanks so much for the easy fix.
Please log in to comment

Answers

0
If it's a managed install, show a screenshot of how you have the MI configured.

My suggestion would be to use the "Override Default Installation" option and give it the full command line, something like:

c:\windows\system32\msiexec.exe /i yourmsiname.msi /qn
Answered 05/13/2015 by: jknox
Red Belt

Please log in to comment
0
This error is not related to the MSI itself but it most likely a syntax error in the command line you are using. As jknox has posted above, we need to see how you have the managed install configured.  
Answered 05/14/2015 by: EdT
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity